Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

PutHBaseJSON error - controller service is disabled

Solved Go to solution

PutHBaseJSON error - controller service is disabled

New Contributor

Hi,

I am trying to push data in to HBase. It was working fine on my personal PC.

Trying to do same on a VM - running with Ubuntu 14.04 server. Not able to do it.

It keeps on poping the error - controller service is disabled and data is not getting stored on Hbase.

12715-issue.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: PutHBaseJSON error - controller service is disabled

Hi @Jay See,

The processor you are trying to use is using a Controller Service. You need to start this controller service to have your processor running correctly. Please go in the configuration of your processor:

screen-shot-2017-02-21-at-92213-am.png

Then click on the arrow at the right of the line of the controller service property to get to the page where you can define/enable your controller service:

12750-screen-shot-2017-02-21-at-92235-am.png

Ensure the controller service is correctly configured and enabled.

Hope this helps.

5 REPLIES 5

Re: PutHBaseJSON error - controller service is disabled

New Contributor

Nifi is not able to connect to zookeeper also.

Even though all hadoop, hbase, zookeeper, and nifi services are running.

ubuntu@ubuntu-14:~$ jps

24211 RunNiFi

24228 NiFi 4965

HQuorumPeer

5031 HMaster

871 Jps

3992 SecondaryNameNode

3562 NameNode

4331 NodeManager

3755 DataNode

5165 HRegionServer

4158 ResourceManager

12720-issue2.png

Re: PutHBaseJSON error - controller service is disabled

Hi @Jay See,

The processor you are trying to use is using a Controller Service. You need to start this controller service to have your processor running correctly. Please go in the configuration of your processor:

screen-shot-2017-02-21-at-92213-am.png

Then click on the arrow at the right of the line of the controller service property to get to the page where you can define/enable your controller service:

12750-screen-shot-2017-02-21-at-92235-am.png

Ensure the controller service is correctly configured and enabled.

Hope this helps.

Re: PutHBaseJSON error - controller service is disabled

New Contributor

Hi @Pierre Villard,

as mentioned in the post. I have working system. I have Hbase_1_1_2_ClientService but it is not throwing some kind of error, which I am not able to understand.

Screen shot from non working machine.

12765-fig3.png

Re: PutHBaseJSON error - controller service is disabled

Your controller service is throwing errors and is saying that it cannot connect to Zookeeper. Did you correctly update the configuration of your controller service to match your new environment? (configuration file, zookeeper quorum, etc). Also, you may find more details about the errors by looking at the logs (./logs/nifi-app.log).

Re: PutHBaseJSON error - controller service is disabled

New Contributor

Thanks @Pierre Villard for your help.

I found the problem, it was with the port.

Don't have an account?
Coming from Hortonworks? Activate your account here