Support Questions
Find answers, ask questions, and share your expertise

Python Version concerning Ambari 2.5.2 or 2.6 on CentOS 6 ?

Hi,

in the documentation (https://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.6.0/bk_support-matrices/content/ch_matrices-amb...) for the upgrade of Ambari (2.4.2 to 2.5.2 or 2.6) and the python version needed (Software Requirements), the version of python for CentOS 6 is not indicated. (for CentOS 7 -> python 2.7, for CentOS 6 -> nothing). What python version is needed for Ambari 2.5.2 (or later) on CentOS 6 ?

Best Regards

Gerald

1 ACCEPTED SOLUTION

@Gerald BIDAULT,

As you are using CentOS 6, I suggest you to use python 2.6.*. (which is what is installed by default). It is not recommended to use python 2.7 on CentOS6.

Python 2.6 is the mininum required version. You cant go below that

Thanks,

Aditya

View solution in original post

2 REPLIES 2

@Gerald BIDAULT,

As you are using CentOS 6, I suggest you to use python 2.6.*. (which is what is installed by default). It is not recommended to use python 2.7 on CentOS6.

Python 2.6 is the mininum required version. You cant go below that

Thanks,

Aditya

Thank's a new time for your quick answer.

Kind Regards

Gérald

; ;