Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

RStudio installation on Hortonworks Sandbox

Super Collaborator

I am trying to install R-studio on Hortonworks sandbox 2.5, downloaded this rpm:

rstudio-server-rhel-0.99.893-x86_64.rpm

After installing this package, when I am running rstudio-server verify-installation, it shows me the following message:

initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused

I have tried starting, stopping rstudio server, it shows the same message. Has anyone experienced this before? Please help.

PS: Since it is a docker container, 8787 port is not opened so I have configured /etc/rstudio/rserver.conf to use port 8090.

1 ACCEPTED SOLUTION

Super Collaborator

It is working now, please follow the below steps:

  1. wget https://download2.rstudio.org/rstudio-server-rhel-0.99.893-x86_64.rpm
  2. sudo yum install --nogpgcheck rstudio-server-rhel-0.99.893-x86_64.rpm
  3. ln -s /usr/lib64/libssl.so.10 /usr/lib64/libssl.so.6
  4. ln -s /usr/lib64/libcrypto.so.10 /usr/lib64/libcrypto.so.6
  5. yum install dpkg
  6. dpkg-divert --local --rename --add /sbin/initctl
  7. ln -s /bin/true /sbin/initctl
  8. yum install R
  9. rstudio-server verify-installation

Please change the default port from 8787 to 8090 as this port is not opened in the docker sandbox

Go to file /etc/rstudio/rserver.conf and add this entry : www-port = 8090

Restart the server by typing exec /usr/lib/rstudio-server/bin/rserver. It will take you out from the docker shell but you can relogin. Go to browser anyway and access RStudio by typing 127.0.0.1:8090. The login page will appear, use user credentials maria_dev/maria_dev

View solution in original post

5 REPLIES 5

I the same problem

03 Nov 2016 07:08:50 [rsession-rstudio-server] ERROR r error 4 (R code execution error) [errormsg=Error in tools:::httpdPort > 0L :                                            
  comparison (6) is possible only for atomic and list types                                                                                                                    
]; OCCURRED AT: core::Error r::exec::<unnamed>::evaluateExpressionsUnsafe(SEXPREC*, SEXPREC*, SEXPREC**, r::sexp::Protect*) /root/rstudio/src/cpp/r/RExec.cpp:148; LOGGED FROM:
 core::Error session::modules::help::initialize() /root/rstudio/src/cpp/session/modules/SessionHelp.cpp:892                                                                    
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused 

Super Collaborator

It is working now, please follow the below steps:

  1. wget https://download2.rstudio.org/rstudio-server-rhel-0.99.893-x86_64.rpm
  2. sudo yum install --nogpgcheck rstudio-server-rhel-0.99.893-x86_64.rpm
  3. ln -s /usr/lib64/libssl.so.10 /usr/lib64/libssl.so.6
  4. ln -s /usr/lib64/libcrypto.so.10 /usr/lib64/libcrypto.so.6
  5. yum install dpkg
  6. dpkg-divert --local --rename --add /sbin/initctl
  7. ln -s /bin/true /sbin/initctl
  8. yum install R
  9. rstudio-server verify-installation

Please change the default port from 8787 to 8090 as this port is not opened in the docker sandbox

Go to file /etc/rstudio/rserver.conf and add this entry : www-port = 8090

Restart the server by typing exec /usr/lib/rstudio-server/bin/rserver. It will take you out from the docker shell but you can relogin. Go to browser anyway and access RStudio by typing 127.0.0.1:8090. The login page will appear, use user credentials maria_dev/maria_dev

HI,I install it success!

but when I login the rstudio server with maria_dev,it apears an error shows me "unable to connect service"

is there any setting I didn't done well?

also when I close hortonworks sandbox, it cannot connect to port 9080

Super Collaborator

@WeiHsiang Tseng, Firstly, try with 8090, not 9080. When you say close, what you are referring to? Have you logout from the shell or power off the image from VirtualBox. In the latter case, if your Sandbox is not up and running, you will not be able to access 8090 port