Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created on
11-16-2021
04:50 AM
- last edited on
04-21-2026
01:03 AM
by
GrazittiAPI
Tried testing the ranger service connection and it is getting failed with message "JAAS configuration missing or not correct in Ranger"
Ranger-admin log:
2021-11-16 12:00:58,661 ERROR org.apache.ranger.services.kafka.RangerServiceKafka: <== RangerServiceKafka.validateConfig Error:java.lang.Exception: JAAS configuration missing or not correct in Ranger Kafka Service...bootstrap.servers,security.protocol,sasl.mechanism,kafka.keytab,kafka.principal
2021-11-16 12:00:58,661 ERROR org.apache.ranger.biz.ServiceMgr: TimedCallable.call: Error:java.lang.Exception: JAAS configuration missing or not correct in Ranger Kafka Service...bootstrap.servers,security.protocol,sasl.mechanism,kafka.keytab,kafka.principal
2021-11-16 12:00:58,662 ERROR org.apache.ranger.biz.ServiceMgr: ==> ServiceMgr.validateConfig Error:org.apache.ranger.plugin.client.HadoopException: java.lang.Exception: JAAS configuration missing or not correct in Ranger Kafka Service...bootstrap.servers,security.protocol,sasl.mechanism,kafka.keytab,kafka.principal
Is jaas file created automatically on ranger.?
cloudMaanger: 7.5.1
Parcel Version: 7.1.7-1.cdh7.1.7.p0.15945976
Created 11-18-2021 12:38 AM
Hi @Ani1991 ,
Suspecting Kerberos related parameters are incorrectly configured in the Kafka service repo in Ranger.
Can you please try the below solution :
-- Ranager Admin UI > edit kafka service repo cm_kafka > Add configs in "Add New Configurations"
-- Add below configs. (Change the config accordingly) for protocol
bootstrap.servers <kafkaBroker>:Port
security.protocol SASL_PLAINTEXT
sasl.mechanism GSSAPI
kafka.keytab <keytab>
kafka.principal <prinicipal>
This config needs a kafka keytab path , copy kafka keytab to ranger admin host with ranger:ranger permissions set.
Created 11-18-2021 12:38 AM
Hi @Ani1991 ,
Suspecting Kerberos related parameters are incorrectly configured in the Kafka service repo in Ranger.
Can you please try the below solution :
-- Ranager Admin UI > edit kafka service repo cm_kafka > Add configs in "Add New Configurations"
-- Add below configs. (Change the config accordingly) for protocol
bootstrap.servers <kafkaBroker>:Port
security.protocol SASL_PLAINTEXT
sasl.mechanism GSSAPI
kafka.keytab <keytab>
kafka.principal <prinicipal>
This config needs a kafka keytab path , copy kafka keytab to ranger admin host with ranger:ranger permissions set.