Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ranger UI not seen

Ranger UI not seen

New Contributor

Hi, we are trying to automate Ranger 0.4 installation. Everything works fine and when ranger admin is started using command: service ranger-admin start, it also shows output as: Apache Ranger Admin has started. But, the Ranger UI is not seen. After some investigation, we noticed that this issue occurs when we try to ssh to that instance. When we start the service manually the UI is seen. Please provide some inputs on this issue. Thanks in advance.

4 REPLIES 4

Re: Ranger UI not seen

Super Guru

@Pooja Kamle

Can you please elaborate more on this with commands and output? By any chance ranger-admin is also installed on the host from where you are running ssh command? In that case you should check it by running "ps -ef|grep -i ranger" on both the hosts just to confirm on which host your script is starting the service.

Hope this helps!

Re: Ranger UI not seen

@Pooja Kamle

In addition to what @Kuldeep Kulkarni mentioned can you also attach the script here, it might be the case that ranger admin is starting earlier than expected.

Highlighted

Re: Ranger UI not seen

Contributor

hi @Pooja Kamle: On a multinode cluster, Ranger can be installed on any of the nodes/ hosts. You need to use the same node's address in UI url as the one on which Ranger is enabled. Also, in case you have SSL (wire encryption) ON, you will need to use following url to open Ranger UI: https://<host>:6182.

@Kuldeep Kulkarni's suggestion to make sure that Ranger Admin is actually up and running by doing ps -ef is a valid suggestion.

If you are facing some other issue, can you pls provide some more details here..

Re: Ranger UI not seen

@Pooja Kamle

when you do service ranger-admin start it starts the tomcat service, but in background still ranger is actually getting starting up, so can you please check xa_portal.log , whether you see any exception there , and as @Anuja Leekha mentioned please check if it is running in ssl mode if it is ssl mode then you can access UI using https://<host>:6182