Support Questions

Find answers, ask questions, and share your expertise

Ranger policies for HDFS not applied,Ranger policy for HDFS not applied

rangergif1.jpegrangergif2.jpegHi, I have created a test directory in hdfs and set the permissions for this to 000. I have then created a Ranger policy to give rwx permissions to a specific user. I am not able to run any Hadoop fs command on this path. It always says access denied. Please see attached gifs.

,

Hi, I have set the permissions for a hdfs directory as 000. I have then enabled led rwx permissions for this directory in Ranger for this user. However I always get access denied with I try to do any Hadoop fs operation on this path.


rangergif3.jpeg
3 REPLIES 3

Super Guru
@Krish Khambadkone

Can you please try setting the follosing to false in ranger-hdfs-security.xml

"xasecure.add-hadoop-authorization" = false

One more thing. I do not see the the hdfs plugin when I go to the Ranger-->Audit tab. I also did the manual plugin installation step by running ./enable-hdfs-plugin.sh from the ranger-hdfs-plugin directory

I also tried setting "xasecure.add-hadoop-authorization" = false but get the same error.

What am I missing here. I believe I have followed all the steps and put the right policies in place. Could someone please help

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.