Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Ranger policies for HDFS not applied,Ranger policy for HDFS not applied

Ranger policies for HDFS not applied,Ranger policy for HDFS not applied

New Contributor

rangergif1.jpegrangergif2.jpegHi, I have created a test directory in hdfs and set the permissions for this to 000. I have then created a Ranger policy to give rwx permissions to a specific user. I am not able to run any Hadoop fs command on this path. It always says access denied. Please see attached gifs.

,

Hi, I have set the permissions for a hdfs directory as 000. I have then enabled led rwx permissions for this directory in Ranger for this user. However I always get access denied with I try to do any Hadoop fs operation on this path.


rangergif3.jpeg
3 REPLIES 3

Re: Ranger policies for HDFS not applied,Ranger policy for HDFS not applied

Super Guru
@Krish Khambadkone

Can you please try setting the follosing to false in ranger-hdfs-security.xml

"xasecure.add-hadoop-authorization" = false

Re: Ranger policies for HDFS not applied,Ranger policy for HDFS not applied

New Contributor

One more thing. I do not see the the hdfs plugin when I go to the Ranger-->Audit tab. I also did the manual plugin installation step by running ./enable-hdfs-plugin.sh from the ranger-hdfs-plugin directory

Re: Ranger policies for HDFS not applied,Ranger policy for HDFS not applied

New Contributor

I also tried setting "xasecure.add-hadoop-authorization" = false but get the same error.

What am I missing here. I believe I have followed all the steps and put the right policies in place. Could someone please help

Don't have an account?
Coming from Hortonworks? Activate your account here