Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Registering hosts failed

Highlighted

Registering hosts failed

Explorer

Hi,

I am installing a cluster on the Ambari server. At the step of registering hosts (installing agents?), the server gets the installation succeeded but the other two hosts are failing with the following error message:

chmod: cannot access ‘/var/lib/ambari-agent/data’: No such file or directory

Seeking help from experts.

thanks

Angelo

6 REPLIES 6
Highlighted

Re: Registering hosts failed

Super Mentor

@Angelo Alexander

Do you have any issue with the Ambari Repo?

Are you able to access the Ambari via Yum? Please share the /etc/yum.repos.d/ambari.repo.

.

1. Additionally if you have any issue while accessing the Ambari Repo (or the RPMs from ambari repo) Or if there is any Internet issue, then you might want to consider using Offline Local repositories as described in:

https://docs.hortonworks.com/HDPDocuments/Ambari-2.4.2.0/bk_ambari-installation/content/using_a_loca...

.

2. Also please check if there is any network proxy setting that might be preventing yum to not be able to download the RPMs properly from ambari repo. Like:

https://docs.hortonworks.com/HDPDocuments/Ambari-2.2.2.0/bk_ambari_reference_guide/content/ch_settin...

Highlighted

Re: Registering hosts failed

Explorer

ambari.repo file

#VERSION_NUMBER=2.4.2.0-136

[Updates-ambari-2.4.2.0]

name=ambari-2.4.2.0 - Updates

baseurl=http://public-repo-1.hortonworks.com/ambari/centos7/2.x/updates/2.4.2.0

gpgcheck=1

gpgkey=http://public-repo-1.hortonworks.com/ambari/centos7/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins

enabled=1

priority=1

++++++++++++++++++++

I may have internet connectivity issue but I am able to ping internet sites though. How do I know about issues accessing Ambari repo?

thanks

Highlighted

Re: Registering hosts failed

Super Mentor

@Angelo Alexander

In any of the agent host try to install the Ambari-agent manually (where it is failing via ambari).

yum install ambari-agent -y

To see if you are getting it installed properly or not?

Also looking at the "/var/log/yum.log" can give some more idea.

.

Highlighted

Re: Registering hosts failed

Highlighted

Re: Registering hosts failed

Explorer

I did yum install ambari-agent -y from each failing host and ran the registration again from Ambari cluster set up and all succeeded. This is not exactly the way in the instructions so not sure if this is ok.

Highlighted

Re: Registering hosts failed

Super Mentor

@Angelo Alexander

In the problematic hosts due to some reasons looks like the amabri-agent was not installed properly hence doing following manually is ok :

yum install ambari-agent -y

- However if you want to find out the cause of failure then may be looking at the old "/var/log/yum.log" might help.

Don't have an account?
Coming from Hortonworks? Activate your account here