Support Questions
Find answers, ask questions, and share your expertise

Registration with the server failed, just when registering Server

Explorer

Hi, I just configuring ambari, but I got the problem when at step 3 on cluster installation. I already following the instruction from

http://docs.hortonworks.com/HDPDocuments/Ambari-2.4.1.0/bk_ambari-installation/content/select_versio...

but it happen, and I don't know what I have to do, actually this same problem already asked in this community, but I can't find the solution.

8138-screenshot-from-2016-09-30-003639.png

Can anybody tell me why it happen ?

and I already check the log file at

/var/log/ambari-server/ambari-server.log

and there is the message

30 Sep 2016 00:21:49,691  INFO [qtp-ambari-agent-82] HeartBeatHandler:332 - HeartBeatHandler.sendCommands: sending ExecutionCommand for host slave1.local, role check_host, roleCommand ACTIONEXECUTE, and command ID 24-0, task ID 117
30 Sep 2016 00:21:50,217  WARN [ambari-action-scheduler] ExecutionCommandWrapper:185 - Unable to lookup the cluster byt ID; assuming that there is no cluster and therefore no configs for this execution command: Cluster not found, clusterName=clusterID=-1
30 Sep 2016 00:21:50,218  WARN [ambari-action-scheduler] ExecutionCommandWrapper:185 - Unable to lookup the cluster byt ID; assuming that there is no cluster and therefore no configs for this execution command: Cluster not found, clusterName=clusterID=-1
30 Sep 2016 00:21:51,223  WARN [ambari-action-scheduler] ExecutionCommandWrapper:185 - Unable to lookup the cluster byt ID; assuming that there is no cluster and therefore no configs for this execution command: Cluster not found, clusterName=clusterID=-1
30 Sep 2016 00:21:51,223  WARN [ambari-action-scheduler] ExecutionCommandWrapper:185 - Unable to lookup the cluster byt ID; assuming that there is no cluster and therefore no configs for this execution command: Cluster not found, clusterName=clusterID=-1
30 Sep 2016 00:21:52,228  WARN [ambari-action-scheduler] ExecutionCommandWrapper:185 - Unable to lookup the cluster byt ID; assuming that there is no cluster and therefore no configs for this execution command: Cluster not found, clusterName=clusterID=-1
30 Sep 2016 00:21:53,241  WARN [ambari-action-scheduler] ExecutionCommandWrapper:185 - Unable to lookup the cluster byt ID; assuming that there is no cluster and therefore no configs for this execution command: Cluster not found, clusterName=clusterID=-1

Quick response really apreciate Thank you

14 REPLIES 14

Cloudera Employee

Are all of the Hostnames and IP's in the /etc/hosts file?

Explorer

@Scott Summers

yes, the Hostnames and IP's are in the /etc/hosts

here is my conf. hosts

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
::1         localhost localhost.localdomain localhost6 localhost6.localdomain6
10.5.1.114      master.local
10.5.1.115      slave1.local
10.5.1.116      slave2.local
10.5.1.142      slave3.local

is anything wrong there ?

Mentor

@aditya alvinsyah

There are a couple of issues you need to be systematic to eliminate the errors ! Though they seem trivial you need to be sure ,if you are running on Linux simple things like ntpd can cause havoc

Have a look at this document and make sure all the steps were followed

Something else on the Management (Ambari server) make sure the directory and file has the correct permissions

/root/.ssh/* 

If using pdsh reboot all the servers and restart the Ambari process .

Hope that helps

Explorer

@Geoffrey Shelton Okot

Thank you sir,

But unfortunately that problem still happen.

I already following all the instructions from that document sir, actually I did it before I preparing to install the cluster, there's no anything wrong when I did, but only I just can't run this command

[root@master /]# ntpdate pool.ntp.org
Exiting, name server cannot be used: Temporary failure in name resolution (-3)30 Sep 06:26:52 ntpdate[2812]: name server cannot be used: Temporary failure in name resolution (-3)


I'm running on Centos 6.x by the way

Mentor

@aditya alvinsyah

There should be a network configuration problem. Have you done the following

# yum install ntp ntpdate
#chconfig ntpd on
#service ntpd start

Don't remove the first 2 lines in your /etc/hosts which looks like this

# Do not remove the following line, or various programs# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6

If removed it your network wont function

Also make sure DNS on your machine is working.

nslookup www.hotmail.com

Explorer

@Geoffrey Shelton Okot

I just try to fix and adding a DNS in

[root@master /]# vi /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE=eth0
HWADDR=6A:50:2A:95:E2:A5
TYPE=Ethernet
UUID=731260b9-1e5c-488e-99a1-774bfd045513
ONBOOT=yes
NM_CONTROLLED=yes
BOOTPROTO=static
IPADDR=10.5.1.114
NETMASK=255.255.255.0
GATEWAY=10.5.1.1
DNS1=8.8.8.8
DNS2=4.4.4.4

and check DNS using nslookup

[root@master /]# nslookup www.hotmail.com
Server:        8.8.8.8
Address:    8.8.8.8#53

Non-authoritative answer:
www.hotmail.com    canonical name = dispatch.kahuna.glbdns2.microsoft.com.
Name:    dispatch.kahuna.glbdns2.microsoft.com
Address: 65.55.157.144
Name:    dispatch.kahuna.glbdns2.microsoft.com
Address: 65.55.157.145

and try to do ntpdate again, and there is a different error message , and I try to fix it with stoping ntpd service first and do a ntpdate, (base on this link :

http://superuser.com/questions/639202/updating-time-ntpdate3108-the-ntp-socket-is-in-use-exiting/639... )

[root@master /]# ntpdate pool.ntp.org
30 Sep 13:59:53 ntpdate[8048]: the NTP socket is in use, exiting
[root@master /]# service ntpd stop
Shutting down ntpd:                                        [  OK  ]
[root@master /]# ntpdate pool.ntp.org
30 Sep 14:12:59 ntpdate[8230]: no server suitable for synchronization found

Mentor

@aditya alvinsyah

Sounds good happy Hadooping

Explorer

@Geoffrey Shelton Okot

Sorry, the problem still happen, I still can't registering the Master.

Maybe any other advice ,Sir ?

Thank you

Please check firewall on server and check selinux on

vi /etc/selinux/config

change the parameter of selinux=enforcing to selinux=disbaled.

And also check if ambari-agent port 8440 and 8441 is used by any other process.

Please check also ntp. And also are you able to do passwordless ssh on same server. If not then please configure passwordless ssh on same server.

And try to add nameserver 8.8.8.8 in /etc/resolved.conf

Or:-

Try to install ambari-agent manually and run below command

  1. ambari-agent reset <ambari-server-hostname-fqdn>

Once agent is bootstrapped then start ambari agent using below command

  1. service ambari-agent start

Note - While installing services on this problematic agent, you can add it via Ambari and click on manual registration to continue.