Support Questions
Find answers, ask questions, and share your expertise

Remove header from "ExecuteSQL" processor

New Contributor

Bom dia,

 

Estou utilizando o Apache Nifi para realizar migração de dados entre banco de dados (Oracle). Preciso extrair um dado BLOB e inseri-lo no DB de destino, mas ao realizar a leitura destes BLOB's via "ExecuteSQL" o Nifi está incorporando um cabeçalho na primeira linha. A solução seria simples, utilizar um "ReplaceText" e retirar estes caracteres indesejados, mas não posso manipular meu dados desta forma, pois estão em Bytes (BLOB) caso eu submeta estes Bytes a algum processor, estes perderão o tipo byte e com isso o meu dado.
Existe alguma forma de retirar o cabeçalho inserido pelo NIFI no processor "executeSQL"? Li a documentação e não encontrei uma configuração para retirar este cabeçalho indesejado.


Obrigado!

 

Screenshot_1.png

 

Good morning,

 

I'm using Apache Nifi to perform data migration between databases (Oracle). I need to extract a BLOB data and insert it in the destination DB, but when reading from the blob via "ExecuteSQL" Nifi is incorporating a header in the first line. The solution would be simple, use a "ReplaceText" and remove these unwanted characters, but I can't manipulate my data this way, as they are in Bytes (BLOB) if I submit these Bytes to some processor, they will lose the byte type and with that the my data. Is there any way to remove the header inserted by NIFI in the "executeSQL" processor? I read the documentation and I haven't found a setting to remove this unwanted header.

 

Thanks!

0 REPLIES 0
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.