Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Repository for OS not available for Isilon OneFS 8.0.0.7 with Ambari 2.6.2.2, HDP 2.6.4.

Highlighted

Repository for OS not available for Isilon OneFS 8.0.0.7 with Ambari 2.6.2.2, HDP 2.6.4.

New Contributor

Hi,

I am trying to create a HDP Cluster using Isilon. This are the versions I'm using.

Isilon OneFS 8.0.0.7

HDP 2.6.4

Ambari 2.6.2.2

CentOS Linux release 7.6.1810 (Core) (Computing Cluster with 3 masters and 5 workers)

109822-ambari-warning.png

After registering the hosts this next warning

Host <IsilonSmartConnectzone> is redhat6 OS type, but the repositories chosen in "Select Stack" step was redhat7. Selected repositories do not support this host OS type.

If I ignore it and proceed with the installation, the "install, start and test" process get stuck in 0%. This is what ambari-server.log has:

java.lang.RuntimeException: org.apache.ambari.server.controller.spi.SystemException: Operating System matching redhat6 could not be found
at org.apache.ambari.server.actionmanager.ExecutionCommandWrapper.getExecutionCommand(ExecutionCommandWrapper.java:253)
at org.apache.ambari.server.actionmanager.ActionScheduler.processInProgressStage(ActionScheduler.java:704)
at org.apache.ambari.server.actionmanager.ActionScheduler.doWork(ActionScheduler.java:417)
at org.apache.ambari.server.actionmanager.ActionScheduler.run(ActionScheduler.java:310)
at java.lang.Thread.run(Thread.java:745)
Caused by: org.apache.ambari.server.controller.spi.SystemException: Operating System matching redhat6 could not be found
at org.apache.ambari.server.state.stack.upgrade.RepositoryVersionHelper.getOSEntityForHost(RepositoryVersionHelper.java:422)
at org.apache.ambari.server.actionmanager.ExecutionCommandWrapper.getExecutionCommand(ExecutionCommandWrapper.java:247)


I found there is a patch to resolve a similar issue for another Ambari version https://issues.apache.org/jira/browse/AMBARI-21211?attachmentOrder=desc But, I did not found anything for 2.6.2.2.


L. Florian





Don't have an account?
Coming from Hortonworks? Activate your account here