Support Questions
Find answers, ask questions, and share your expertise

Required config(s): mapred-logsearch-conf is(are) not available for service MAPREDUCE2 with service config version XX in cluster

Explorer

Following an apparently successful Ambari upgrade from v2.4.2 to 2.5.0.3, Ambari server is refusing to start with the error,

DB configs consistency check failed. Run "ambari-server start --skip-database-check" to skip. You may try --auto-fix-database flag to attempt to fix issues automatically. If you use this "--skip-database-check" option, do not make any changes to your cluster topology or perform a cluster upgrade until you correct the database consistency issues. See /var/log/ambari-server/ambari-server-check-database.log for more details on the consistency issues.
ERROR: Exiting with exit code -1.
REASON: Ambari Server java process has stopped. Please check the logs for more information.

The log shows:

2017-04-18 14:48:51,844 ERROR - Required config(s): mapred-logsearch-conf is(are) not available for service MAPREDUCE2 with service config version 12 in cluster mycluster 

2017-04-18 14:48:51,844 ERROR - Required config(s): yarn-logsearch-conf is(are) not available for service YARN with service config version 19 in cluster mycluster

This appears to be a bug: https://issues.apache.org/jira/browse/AMBARI-18822

How can I work around this issue and execute a cluster upgrade from 2.5.3 to 2.6?

Thanks in advance!