Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Solved Go to solution

ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Contributor

I installed Ambari, but cannot start ResourceManager. I followed different indications that I found in this forum, but nothing helped so far. In particular, UI shows the following error :

"Connection failed to http://eureambarislave1.local.eurecat.org:8088 (<urlopen error [Errno 111] Connection refused>)"

But the port 8088 is opened and proxy is setup.

69469-screen-shot-2018-04-14-at-105420.png

The output of "jps" in ResourceManager host:

# jps

9953 QuorumPeerMain

15683 RMAdminCLI

17508 NodeManager

15813 RMAdminCLI

19881 RunJar

11435 RMAdminCLI

4428 RunJar

16428 RMAdminCLI

23535 SecondaryNameNode

11760 RMAdminCLI

19313 Jps

5811 RunJar

15923 RMAdminCLI

16053 RMAdminCLI

11319 RMAdminCLI

17241 ApplicationHistoryServer

27546 JobHistoryServer

11675 RMAdminCLI

22687 DataNode

11519 RMAdminCLI

Is it fine that I have so many processes of "RMAdminCLI"?

Also, I cannot open http://xxx.xx.xx.xx:8088 in the browser.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Contributor

I solved this problem by opening the ports 2888 and 3888 that are used by ZooKeeper nodes for communicating between each other.

14 REPLIES 14

Re: ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Contributor

I found ResourceManager logs in "/var/log/hadoop-yarn"

2018-04-12 22:41:29,700 INFO resourcemanager.ResourceManager (LogAdapter.java:info(45)) -

STARTUP_MSG: /************************************************************

STARTUP_MSG: Starting ResourceManager

STARTUP_MSG: user = yarn

STARTUP_MSG: host = eureambarislave1.local.eurecat.org/192.168.0.10

STARTUP_MSG: args = [] STARTUP_MSG: version = 2.7.3.2.6.4.0-91

Re: ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Rising Star

@Liana Napalkova The jps output doesn't show ResourceManager process. RMAdminCli is the process which runs when "yarn rmadmin" command is executed. Not exactly sure who is executing it, but that shouldn't be a problem. Is ResourceManager service showing started in ambari?

Re: ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Contributor

The "jps" command shows that ResourceManager is running. However, there is an alert next to ResourceManager that says "Connection failed to http://eureambarislave2.local.eurecat.org:8088 (<urlopen error [Errno 111] Connection refused>). I restarted everything several times and checked that the port 8088 is opened. But the error still exists. I cannot access ResourceManager in a browser.

Re: ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Contributor

By the way, this is how I opened the port 8088:

iptables -I INPUT 1 -p tcp --dport 8088 -j ACCEPT

Also, I created a TCP security rule for 8088.

What do I miss?

Re: ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Rising Star

Can you check if ResourceManager is listening on port 8088 as follows.

ps -ef | grep `lsof -i :8088 | grep -i listen | awk '{print $2}'`

If the command returns no output, then we can check for errors in resourcemanager logs. By default the location is /var/log/hadoop-yarn/yarn/

Re: ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Contributor

I get the following output after running this command:

root 811 31804 0 08:51 pts/0 00:00:00 grep --color=auto lsof -i :8088 | grep -i listen | awk '{print }'

But the command "netstat -tunalp | grep LISTEN" does not show the port 8088.

Re: ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Rising Star

I think you typed in ' quote instead of ` . Can you give the full output of the following commands instead.

jps -l | grep -i resourcemanager

netstat -anp | grep 8088
Highlighted

Re: ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Contributor

This is what I get:

# jps -l | grep -i resourcemanager

4274 org.apache.hadoop.yarn.server.resourcemanager.ResourceManager

# netstat -anp | grep 8088 [root@eureambarislave2 sbin]

#

The netstat returns nothing.

Re: ResourceManager is started with alerts and ip:8088 is not accessible in the browser.

Rising Star

Do you see any errors in Resourcemanager logs? They are usually at /var/log/hadoop-yarn/yarn/ . Do you have ResourceManager HA enabled?

Don't have an account?
Coming from Hortonworks? Activate your account here