Support Questions

Find answers, ask questions, and share your expertise

SELinux enabled error though set it to permissive and rebooted the machine

New Contributor

Hello Community,

 

I am installing Cloudera Manager on RHEL7.4 AMI in AWS . As per the instructions, i set SELINUX=permissive and rebooted the machine. But i am getting the error "SELinux is enabled it should be disabled " while running the Manager bin file. 

Are the instructions correct ? Any help in this regrad is much appreciated 

 

------------ update ------------

I tried with Cenos6.5 AMI and it works . The /etc/selinux/config fille in CentOs has "SELINUX=disabled" while  for RHEL 7.4 it's "SELINUX=enforcing". For RHEL7.4 when i set the SELINUX to disabled the VM doesn't even comes up. Well CentOs6.5 worked for me so i will stick to it

 

 

2 REPLIES 2

Rising Star

For RHEL 7 you can go in single user mode  and do a "./autorelabel" and then try. It should work. Let me know if any error arises.

Expert Contributor

Setting selinux to disabled in RHEL 7.4 should work. Unless you are using Oracle Linux, or have installed and trying to boot with the Unbreakable Kernel, for some reason.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.