Support Questions

Find answers, ask questions, and share your expertise

SERVER ERROR: ISSUE WHILE LOGGING INTO AMBARI SERVER UI - URGENT

I'm a newbie to Ambari. I have correctly installed ambari server. The hadoop 2.8 and hive are perfectly running on my machine. I downloaded and installed Ambari server on RHEL 7.4. Everything went fine during installation until the Ambari UI login page appeared on the browser on the port 8080 (localhost:8080). I'm unable to login to the ambari server with default username and password (admin/admin). I have tried many troubleshooting techniques but all in vain. Kindly help me out.

Screenshot of the error is attached below.

62780-ambari-issue.jpg

7 REPLIES 7

Super Mentor

@Muhammad Sarmad Ali

Please check if your ambari-server has come up successfully or not?

Most probably you are entering a wrong credential here. So please check the Ambari Database to see if the password is as following (which is default encrypted password for ambari as 'admin')

# su - postgres -c "psql -d ambari -tc \"select user_password from ambari.users where user_name='admin'\""

.

If the output of the above command is not as following then you will need to reset the amabri password to 'admin'

 538916f8943ec225d97a9a86a2c6ec0818c1cd400e09e03b660fdaaec4af29ddbb6f2b1033b81b00

.

In order to reset ambari user password to 'admin' you will need to run the following query:

# su - postgres -c "psql -d ambari -tc \"update ambari.users set user_password='538916f8943ec225d97a9a86a2c6ec0818c1cd400e09e03b660fdaaec4af29ddbb6f2b1033b81b00' where user_name='admin'\""

Then restart the ambari server and then try to login to ambari with username = admin and password =admin.

If you face any issue then please share the ambari server.log

Thanks Jay for the response. My ambari-server has started successfully. I'm using MySQL with ambari not postgre SQL. Is it necessary to use postgre SQL for first time?

Super Mentor

@Muhammad Sarmad Ali

It is not mandatory to use postgres for the firsxt time you can directly start using ambari with mysql.

However in order to use mysql you will need some additional setup from DB side before you setup ambari to use mysql. These steps are described here: https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.5/bk_ambari-administration/content/using_amba...

If you have already followed the steps mentioned in the above link then you will need to check if the encrypted password is correctly set in the ambari DB or not?

# mysql -u ambari -p
Enter password: bigdata

mysql> use ambari;

mysql> select user_password from users where user_name = 'admin';
+----------------------------------------------------------------------------------+
| user_password                                                                    |
+----------------------------------------------------------------------------------+
| 538916f8943ec225d97a9a86a2c6ec0818c1cd400e09e03b660fdaaec4af29ddbb6f2b1033b81b00 |
+----------------------------------------------------------------------------------+
1 row in set (0.00 sec)

.

If the password is not same as above then you will need to use the update query to set the password as above and then Restart the ambari-server then try to login to ambari ui with admin/admin credentials.

Thanks Jay. I followed the tutorial step by step and every command worked fine. But again, when I tried accessing Ambari server through firefox, the same error popped up. 😞

62783-password.jpg

Super Mentor

@Muhammad Sarmad Ali

After making the changes to the DB .. have you restarted ambari-server?

Can you please share the following two logs when you noticed server error

 /var/log/ambari-server/ambari-server.log
 /var/log/ambari-server/ambari-audit.log

.

AMBARI-AUDIT.LOG:

ambari-audit.txt

AMBARI-SERVER.LOG

ambari-server.txt

Super Mentor

@Muhammad Sarmad Ali

This is the error which is causing the admin user login to fail: Table 'test.members' doesn't exist (where as it is supposed to be inside "ambari" schema as "ambari.members")

09 Mar 2018 12:47:30,722  WARN [ambari-client-thread-35] ServletHandler:561 - Error Processing URI: /api/v1/users/admin - (javax.persistence.PersistenceException) Exception [EclipseLink-4002] (Eclipse Persistence Services - 2.6.2.v20151217-774c696): org.eclipse.persistence.exceptions.DatabaseException
Internal Exception: com.mysql.jdbc.exceptions.jdbc4.MySQLSyntaxErrorException: Table 'test.members' doesn't exist
Error Code: 1146
Call: SELECT member_id, group_id, user_id FROM members WHERE (user_id = ?)
	bind => [1 parameter bound]
Query: ReadAllQuery(referenceClass=MemberEntity sql="SELECT member_id, group_id, user_id FROM members WHERE (user_id = ?)")<br>

.

Looks like inside your ambari DB the tables "members" is missing (so ambari user's membership info it is not able to get). May be because you migth have not choosen the schema name correctly. Usually the ambari DB schema name is "ambari"

If this is fresh installation of ambari then , I will suggest you to do ambari-server reset and also check if you have missed any step mentioned in

https://docs.hortonworks.com/HDPDocuments/Ambari-2.6.1.5/bk_ambari-administration/content/using_amba...

.