Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

SQOOP hive import won't start

Highlighted

SQOOP hive import won't start

New Contributor

I'm trying to import oracle data into Hive with sqoop. Sqoop fetches data from oracle and puts it in hdfs properly.

But when there should be hive import part - it doesn't working. Sqoop writes some info messages, no errors, and quites, without doing any hive import job.

my sqoop invocation is

sqoop import --connect jdbc:oracle:thin:@host:1521:SID --username username --password password --delete-target-dir --table TEST_SQOOP --hive-import --hive-database db -m 1 -verbose

and get such output with verbose (its end)

19/06/03 18:28:02 DEBUG hive.TableDefWriter: Create statement: CREATE TABLE IF NOT EXISTS `db`.`TEST_SQOOP` ( `A` DOUBLE, `B` STRING, `D` STRING) COMMENT 'Imported by sqoop on 2019/06/03 18:28:02' ROW FORMAT DELIMITED FIELDS TERMINATED BY '\001' LINES TERMINATED BY '\012' STORED AS TEXTFILE
19/06/03 18:28:02 DEBUG hive.TableDefWriter: Load statement: LOAD DATA INPATH 'hdfs://hadoop/user/airflow/TEST_SQOOP' INTO TABLE `ds_pud`.`TEST_SQOOP`
19/06/03 18:28:02 DEBUG ipc.Client: The ping interval is 60000 ms.
19/06/03 18:28:02 DEBUG ipc.Client: Connecting to hadoop-m1/ip:8020
19/06/03 18:28:02 DEBUG ipc.Client: IPC Client (2071364564) connection to hadoop-m1/ip:8020 from airflow: starting, having connections 2
19/06/03 18:28:02 DEBUG ipc.Client: IPC Client (2071364564) connection to hadoop-m1/ip:8020 from airflow sending #779
19/06/03 18:28:02 DEBUG ipc.Client: IPC Client (2071364564) connection to hadoop-m1/ip:8020 from airflow got value #779
19/06/03 18:28:02 DEBUG ipc.ProtobufRpcEngine: Call: getFileInfo took 69ms
19/06/03 18:28:02 INFO hive.HiveImport: Loading uploaded data into Hive
Logging initialized using configuration in jar:file:/usr/hdp/2.5.3.0-37/hive/lib/hive-common-1.2.1000.2.5.3.0-37.jar!/hive-log4j.properties

where these "Logging initialized" is its las output message

but nothing happens in Hive. No table created, no data loaded.

If i run hive manually through hive command i'm able to execute Create Table/LOAD DATA INPATH statements without problems.


Why sqoop doesn't do it's Hive job?



Don't have an account?
Coming from Hortonworks? Activate your account here