Support Questions
Find answers, ask questions, and share your expertise

SUSE Ambari Agent can not connect to server

Highlighted

SUSE Ambari Agent can not connect to server

New Contributor

Hi ,

anyone know how to fix the connection fail issue?

Description: SUSE Linux Enterprise Desktop 12 SP2 Release: 12.2

Configuration for agent:

hostname=10.129.126.xx

url_port=8440

secured_url_port=8441

force_https_protocol=PROTOCOL_TLSv1_2

Error Message:

ERROR 2017-12-08 20:51:43,206 Controller.py:226 - Unable to connect to: https://10.129.126.XX:8441/agent/v1/register/pvgl56588672g Traceback (most recent call last): File "/usr/lib/python2.6/site-packages/ambari_agent/Controller.py", line 165, in registerWithServer data = json.dumps(self.register.build(self.version)) File "/usr/lib/python2.6/site-packages/ambari_agent/Register.py", line 43, in build hostInfo.register(agentEnv, False, False) File "/usr/lib/python2.6/site-packages/ambari_agent/HostInfo.py", line 316, in register self.checkLiveServices(self.DEFAULT_LIVE_SERVICES, liveSvcs) File "/usr/lib/python2.6/site-packages/ambari_agent/HostInfo.py", line 73, in checkLiveServices svcCheckResult['name'] = " or ".join(service) TypeError: can only join an iterable ERROR 2017-12-08 20:51:43,206 Controller.py:227 - Error:can only join an iterable

and i debug the code found the service value is None

BTW, the 8440 port connect success and no idea why it still need to connect to 8441

NetUtil.py:90 - GET https://10.129.126.XX:8440/ca -> 200

Thanks for your help and wait for you response

7 REPLIES 7
Highlighted

Re: SUSE Ambari Agent can not connect to server

Mentor

@Bright Gong

Can you backup your ambari-agent.ini and remove the line

force_https_protocol=PROTOCOL_TLSv1_2

And retry

Highlighted

Re: SUSE Ambari Agent can not connect to server

New Contributor

Hi @Geoffrey Shelton Okot, I have already tried before and there is no difference for this error

any suggestion?

Thanks

Bright

Highlighted

Re: SUSE Ambari Agent can not connect to server

Mentor

@Bright Gong

You should try the manual installation see link and in the ambari.ini use FQDN rather than the IP in your case above

[server]
hostname={FQDN_ambari.server.hostname}
url_port=8440
secured_url_port=8441

Please revert

Highlighted

Re: SUSE Ambari Agent can not connect to server

New Contributor

does anyone have faced this issue and can help?

Highlighted

Re: SUSE Ambari Agent can not connect to server

Mentor

@Bright Gong

Port 8441 is the SSL as seen your server URL output is https://10.129.126.XX:8440/ca

Is this a new installation ? Check whether the ambari certificate has expired?

[server]
hostname={FQDN_ambari.server.hostname}
url_port=8440
secured_url_port=8441

Please check this HCC forum answer by Jay Kumar SenSharma

Highlighted

Re: SUSE Ambari Agent can not connect to server

New Contributor

Hi Geoffrey,

is there anyway just to disable the https connection, i use it in our internal network so the http is enough

Thanks

Bright

Highlighted

Re: SUSE Ambari Agent can not connect to server

Mentor

@Bright Gong

If you have a running ambari server already do the below assuming you are running Ambari https://10.129.126.XX it as root, there should be an option to disable SSL. First tke a copy of your ambari.properties probably on Suse in /etc/ambari-server/conf

Then run ,if you have SSL enable you will see the Disable HTTPS option

# ambari-server setup-security


My current non-SSL Ambari output is, but if I had enabled SSL before and want to disable I would get the first option as disable HTTPS

# ambari-server setup-security
Using python  /usr/bin/python
Security setup options...
===========================================================================
Choose one of the following options:
  [1] Enable HTTPS for Ambari server.
  [2] Encrypt passwords stored in ambari.properties file.
  [3] Setup Ambari kerberos JAAS configuration.
  [4] Setup truststore.
  [5] Import certificate to truststore.
===========================================================================
Enter choice, (1-5):

Please can you validate on your Ambari host, you will need to restart the Ambari server after this change