Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Sandbox 2.6.3 Virtualbox VM stopped working. Stuck at cleanup of temporary directories

Highlighted

Sandbox 2.6.3 Virtualbox VM stopped working. Stuck at cleanup of temporary directories

Explorer

Hi,

I have been using the Sandbox 2.6.3 through Virtualbox for the past 2 months. But all of a sudden the CentOs Linux is not booting completely and got stuck at the step :

Started Cleanup of Temporary Directories.

I have waited for hours but no progress. I tried to power off and restart many times.

Tried to update the Virtualbox to the latest version. As it was working fine, wondering why it stopped working!

Could someone please suggest what I need to do to resolve it? I have attached the screenshots for your reference.

I usually leave the system to hibernate and will leave the VM running. I will power it off only after a few days or once in a while.

Do I need to shutdown the VM everyday and restart it ? Please advice

64546-error1.jpg

64547-error2.jpg

7 REPLIES 7
Highlighted

Re: Sandbox 2.6.3 Virtualbox VM stopped working. Stuck at cleanup of temporary directories

Explorer

I had to remove the Sandbox VM from the Oracle virtual box and import again. Still got stuck at the same step "Started Cleanup of Temporary Directories", but surprisingly after a couple of hours, the OS booted successfully.

Unfortunately, I lost all my data that I was saving for the last couple of months! :-(

The issue is resolved, wondering why all this happened in the first place

Thanks!

Re: Sandbox 2.6.3 Virtualbox VM stopped working. Stuck at cleanup of temporary directories

Rising Star

@SUBIN RAJU

Hello, I believe this has to do with the memory constraints of the sandbox where it's usually staying at very close to 100% full. Also, there were issues we found and fixed regarding the Docker FS systems but there might have been some we missed. My recommendation is to use the latest sandbox since the underlying docker tech has evolved quite a bit in the last couple of months.

Highlighted

Re: Sandbox 2.6.3 Virtualbox VM stopped working. Stuck at cleanup of temporary directories

Explorer

Thanks glupu!

I will download the latest version, but will I lose my data which I have been saving all these days?

Is there a way to retain them?

Highlighted

Re: Sandbox 2.6.3 Virtualbox VM stopped working. Stuck at cleanup of temporary directories

Explorer

Hi, I downloaded the latest version as recommended and it was working fine. But after few weeks, I'm now facing the same issue. The booting is again stuck at "Started Cleanup of Temporary Directories" for ever. Could someone suggest me how can I avoid this? This time I used to shutdown/power off the system / VM everyday!

Highlighted

Re: Sandbox 2.6.3 Virtualbox VM stopped working. Stuck at cleanup of temporary directories

New Contributor

Hello,

I experience the same issue on 2 different hosts I tried. After it gets stuck with this "Started Cleaning up" step, it keeps hanging there! This is using latest vm 2.6.4 on Virtual Box.

Is there a non-docker version of VM? There are different options for Docker and NonDocker (Virtual Box and VMWare). But the downloaded VM say's its docker file. Also when booting, VM logs that it's starting docker.

Where is non-docker version of Sandbox?

Highlighted

Re: Sandbox 2.6.3 Virtualbox VM stopped working. Stuck at cleanup of temporary directories

Explorer

Yes, I'm also using the same version 2.6.4 on Virtual Box VM. At least this version shows the cleanup status with dots .....

So, after several hours, I have powered off and restarted again, it booted successfully. But after few days, the same issue is repeated again, have to wait several hours again. It could be good if someone could help providing the correct procedure to use the Virtual Box to avoid this issue.

Highlighted

Re: Sandbox 2.6.3 Virtualbox VM stopped working. Stuck at cleanup of temporary directories

New Contributor

I am also facing the same issue with my HDP VM Sandbox. It says "Started cleanup of temporary directories" for more than 2 hours and then the Login details appear. Testing patience.

I have allocated 12 GBs of RAM and host OS is Windows 10.

The HDP VM Sandbox is 2.6.4.

Can Hortonworks please help with Root Cause and Solution for it.

Any clues from Log Files ??

BJ

Don't have an account?
Coming from Hortonworks? Activate your account here