Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Selecting Cloudera Manager Express vs Enterprise

Highlighted

Selecting Cloudera Manager Express vs Enterprise

Explorer

Hi, I'm having a problem where my automated CDH setup is failing with the following error:

 

2017-04-03 08:15:37,447 - ERROR - Start: Command failed to run because service Cloudera Management Service has invalid configuration. Review and correct its configuration. First error: Service mgmt has 0 Reports Managers. Cloudera Management Service requires at least 1 Reports Manager. (cmd.success is False)

 

When I look in Cloudera Manager, it shows the Enterprise Trial version is active:

Version: Cloudera Enterprise Data Hub Edition Trial 5.9.0

 

Instead of what I expect to see:

Cloudera Express 5.9.0

 

I think this is the cause of the error because the enterprise version requires the reports manager but the express doesn't.

 

I can't work out how it would have activated the trial, my install method is:

 

1. add apt source of: deb [arch=amd64] https://archive.cloudera.com/cm5/ubuntu/trusty/amd64/cm trusty-cm5.9.0 contrib

2. apt-get install cloudera-manager-daemons cloudera-manager-server

3. run /usr/share/cmf/schema/scm_prepare_database.sh

4. Use the Cloudera Manager API to install CMS & then the hadoop services

 

The only way I know of to select the enterprise trial is on the welcome screen. Is there any other way this could have happened? I've read the licensing documentation (https://www.cloudera.com/documentation/enterprise/5-9-x/topics/cm_ag_licenses.html#cmug_topic_13_7__...) and couldn't see anything mentioned that contradicts my previous exerience that it defaults to "express" unless you select another option from the welcome screen.

 

I've been running this automated install method for a few years without this problem before. Any insights would be much appreciated.

 

Thanks,

 

James