Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Simple User Authorization mode is not working in Apache Atlas as expected

Highlighted

Simple User Authorization mode is not working in Apache Atlas as expected

New Contributor

Hello

I am facing 2 issues.

1) I was trying to use the simple authorization model provided by atlas I have made my custom Role with user as 'abhishek' linked to a custom group and tried to modify atlas-simple-authz-policy.json as per the correct syntax. presented in the official documentation.Additionally,I also tried to create another custom role for other user 'tushar' linked to a different group.

Whenever I try to login I get the following error as mentioned below -

2018-11-23 11:04:56,486 ERROR - [pool-1-thread-7 - 1bac333e-78ce-46b7-a7d2-ccc2f62e67ee:] ~ graph rollback due to exception AtlasBaseException:Instance __AtlasUserProfile with unique attribute {name=abhishek} does not exist (GraphTransactionInterceptor:156)

The same error comes in log file even if I successfully login through other user accounts.

Although above error persists but login is successful

2) I am successfully able to login with different user accounts that I mentioned in users-credentials.properties file.However,the custom type that I created from one account (say**

abhishek) are reflected/shown while logging in from different user accounts(say tushar).

Why authorization is not working as expected ?

Kindly suggest for the same.

Thanks in Advance

Don't have an account?
Coming from Hortonworks? Activate your account here