Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

SmartSense Agent refusing to connect after upgrade to Ambari 2.5.1.0

SmartSense Agent refusing to connect after upgrade to Ambari 2.5.1.0

New Contributor

Having a really annoying issue where the agents are refusing to connect to the server. Tried resetting agents via hst reset-agent and tried re-installing smartsense. Here is the error and stack trace from /var/log/hst/hst-agent.log:

INFO 2017-09-26 15:00:01,314 security.py:178 - Server certificate not exists, downloading
INFO 2017-09-26 15:00:01,314 security.py:191 - Downloading server cert from https://serverhost:9440/cert/ca/
ERROR 2017-09-26 15:00:01,370 ServerAPI.py:69 - GET https://serverhost:9441/api/v1/agents failed. (SSLError(1, u'[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:579)'),)
INFO 2017-09-26 15:02:08,491 security.py:178 - Server certificate not exists, downloading
INFO 2017-09-26 15:02:08,492 security.py:191 - Downloading server cert from https://serverhost:9440/cert/ca/
ERROR 2017-09-26 15:02:08,547 ServerAPI.py:84 - GET https://serverhost:9441/api/v1/hst_agents/serverhost failed. (SSLError(1, u'[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:579)'),)

Whenever I try to run hst setup-agent -q after resetting I get the following error:

Failed to register agent with the server. Check SmartSense tool server is running at https://serverhost:9441

Please note, I've removed the host name for security.

Tried doing the following:

https://docs.hortonworks.com/HDPDocuments/SS1/SmartSense-1.4.0/bk_installation/content/SSL_troublesh...

Running SmartSense 1.4.0.2.5.1.0-159 with HDP 2.6.1.129 and Ambari 2.5.1.0

Please note, I've confirmed HST Server is running and up, and I've reset it/uninstalled/reinstalled etc. Any ideas?

3 REPLIES 3

Re: SmartSense Agent refusing to connect after upgrade to Ambari 2.5.1.0

Contributor

Looks like this issue is because python back-ported a fix in 2.7.9 (and above) to 2.7.5 (and other versions). We already fixed this issue in 1.3.x, 1.4.x, etc., branches. If an urgent fix is required, please go ahead and request an HOTFIX.

A simple workaround for this is issue is to disable http.verify in /etc/python/cert_verification.cfg file

# /etc/python/cert_verification.cfg

[http]

verify=disable

Re: SmartSense Agent refusing to connect after upgrade to Ambari 2.5.1.0

Rising Star

Which node would be this file located?

Or where in Ambari can be searched for?

Re: SmartSense Agent refusing to connect after upgrade to Ambari 2.5.1.0

Contributor

The /etc/python/cert_verification.cfg file will be available on all nodes. This change required to be applied on all nodes.