Support Questions

Find answers, ask questions, and share your expertise

Solr 5.0 or above compatibility with Hue

Rising Star

Hi,

 

We are trying to use Solr 5.3 in SolrCloud mode with Hue 3.11

However, we have not been able to run it yet.

We are running both on CentOS 7. We use HDP 2.4.2 with Ambari

 

We think that Solr above 5.0 does not run with Hue, due to a depreciated or missing class: solr.JsonUpdateRequestHandler (see error below).

 

{"responseHeader":{"status":400,"QTime":404},"error":{"metadata":["error-class","org.apache.solr.common.SolrException","root-error-class","java.lang.ClassNotFoundException"],"msg":"Error CREATEing SolrCore 'twitter_demo': Unable to create core [twitter_demo] Caused by: solr.JsonUpdateRequestHandler","code":400}} (error 400)

 

Do you know if it is possible or has been tried before?

 

 

Thanks in advance...

1 REPLY 1

Hue Search Dashboards work with CDH and Solr 4, or any Solr 5 or 6:
http://gethue.com/bay-area-bikeshare-data-analysis-with-search-and-spark-notebook/

Your Solr might not like the Search examples, we did not test those yet,
but you can create your own collections and it will work.
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.