Support Questions
Find answers, ask questions, and share your expertise

Solr 6.6.0 zookeeper 3.4.10 dependency

Solved Go to solution
Highlighted

Solr 6.6.0 zookeeper 3.4.10 dependency

Explorer

The Release notes for Solr 6.6.0 include the following Upgrade Note:

  • ZooKeeper dependency has been upgraded from 3.4.6 to 3.4.10.

On the face of it, this looks like a problem, since even HDP 2.6 only include Zookeeper 3.4.6.

Does this 'dependency' mean that Solr will not work with Zookeeper 3.4.6 or is it just documenting the fact that the Solr embedded Zookeeper instance is now 3.4.10?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Solr 6.6.0 zookeeper 3.4.10 dependency

Explorer

It's only documenting the fact that Solr has updated it's embedded ZooKeeper to 3.4.10. I don't know of any changes that would impact Solr 6.6 working with ZK 3.4.6.

View solution in original post

2 REPLIES 2

Re: Solr 6.6.0 zookeeper 3.4.10 dependency

Explorer

It's only documenting the fact that Solr has updated it's embedded ZooKeeper to 3.4.10. I don't know of any changes that would impact Solr 6.6 working with ZK 3.4.6.

View solution in original post

Highlighted

Re: Solr 6.6.0 zookeeper 3.4.10 dependency

Explorer

Thanks @Cassandra Targett

I didn't think it sounded quite right. We'll give it a try

Tony