Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here. Want to know more about what has changed? Check out the Community News blog.

Sqoop get TCP/IP conection error

Highlighted

Sqoop get TCP/IP conection error

Explorer


Hi all

 

When i tried to conect to a DB when i use the sqoop coman -list-databases i do not have any problem.

 

but when i tried to use de command list-tables y have a conection TCP/IP error.

the Sqoop command: sudo sqoop list-tables --connect jdbc:sqlserver://XXXXXXXXXXX:XXXX/db_test --username XXXXXX --password XXXXXX

 

The erros is the following:

Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: The TCP/IP connection to the host , port XXXX has failed. Error: "null. Verify the connection properties. Make sure that an instance of SQL Server is running           on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by           a firewall.".

If anybody knows something

 

Best regards