Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here. Want to know more about what has changed? Check out the Community News blog.

Sqoop import failing with "Check that JARs for hive datasets are on the classpath"

Highlighted

Sqoop import failing with "Check that JARs for hive datasets are on the classpath"

Expert Contributor

When using "--as-parquetfile" option to do "--hive-import", I'm running into this error:

 

org.kitesdk.data.DatasetNotFoundException: Unknown dataset URI pattern: dataset:hive://<metastore>:9083/<table>
Check that JARs for hive datasets are on the classpath

 

I've also passed the options to set the HIVE_HOME and HCAT_HOME:

 

             --hive-home
             /opt/cloudera/parcels/CDH/lib/hive
             --hcatalog-home
             /opt/cloudera/parcels/CDH/lib/hive-hcatalog

 

Is there anything else that need to be provided to the sqoop action in oozie?

 

Thanks!