Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Sqoop issue with ORA-06502:PL/SQL: numeric or value error


Sqoop issue with ORA-06502:PL/SQL: numeric or value error


Hi All,


We are trying to do a sqoop import to hive from Oracle and struck with a weird error below:



WARN[main] org.apache.hadoop.mapred.YarnChild:

Exception running child : java.sql.SQLException:

ORA-00606:error occurred at recursive SQL level 1

ORA-06502:PL/SQL: numeric or value error : character string buffer too small

ORA-06512:at line 25 at oracle.jdbc.driver.T4CCTTloer11.processError(


Issue seems to be coming from ojdbc8,jar Version below:


java -jar ./usr/lib/sqoop/lib/ojdbc8.jar Oracle JDBC 4.2 compiled with javac 1.8.0_91 on Tue_Dec_13_06:08:31_PST_2016

Default Connection Properties Resource
Mon Feb 10 16:50:46 AEDT 2020



Note that the table has no clob / blob columns and has only NUMBER with a max of 12 byte and VARCHAR with a max of 30 byte.


The job fails with the same error even if the table is empty.


Sqoop command below:

sqoop import --connect 'jdbc:oracle:thin@(description=(address=(protocol=tcp)(host=xxx)(port=xxx)(connect_data=(SERVER=DEDICATED)(service_name=xxx)' --username xxx --password xxx --delete-target-dir --hive-import --hive-database default --hive-table TXN --hive-overwrite --table TXN --target-dir /tmp/TXN -m 1 --verbose


Could you please help on this



Sridar Venkatesan


Re: Sqoop issue with ORA-06502:PL/SQL: numeric or value error


Based on, it looks like a data conversion issue. Have you tried to just import into HDFS without Hive table and see if it makes any difference?

Can you also share the DDL of table TXN in Oracle?

Don't have an account?
Coming from Hortonworks? Activate your account here