Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Stack upgrade using Ambari - Missing version ?

Solved Go to solution
Highlighted

Stack upgrade using Ambari - Missing version ?

New Contributor

Hi,

I want to perform an upgrade on a test cluster (3 vms). The idea is to go from

Ambari 1.7.0 with HDP 2.2.0.0-2041 + Ganglia/Nagios

to

Ambari 2.2.1.0 with HDP 2.4.0.0 + Ambari Metrics

The ambari upgrade worked and the 2.2 hdp cluster is running normally. I haven't any error or alert.

When I register a new version, it is visible from the Manage ambari -> Versions page.

HDP repository

But when I want to perform an upgrade from Admin -> Stack and Versions -> Versions , only the current version is visible.

enter image description here

Why is that so ? What did I miss ?

Services installed :

  • List item
  • HDFS
  • MapReduce
  • YARN
  • Tez
  • Hive
  • Pig
  • Oozie
  • Zookeeper
  • Ambari Metrics
  • Kafka

Thank you for your help !

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Stack upgrade using Ambari - Missing version ?

New Contributor

Hi,

Sorry to answer this late but this did the trick. :

https://community.hortonworks.com/answers/25787/view.html

View solution in original post

7 REPLIES 7
Highlighted

Re: Stack upgrade using Ambari - Missing version ?

Hi @axel couty. I have seen this, and other similar strange behaviour before, usually when there's been some form of network instability between the users browser and the ambari server. It seems to get the Ambari database into a strange condition.

If that's the case, you may need to perform some database hacking to fix it, however before you descend into that, have you tried restarting the ambari server first and seeing if once it comes back up the new versions appear now?

Highlighted

Re: Stack upgrade using Ambari - Missing version ?

New Contributor

Hi @drussell. yes I restarted everything between each version registration on ambari. Also, I restarted the stack etc..

Thank you for the database information, it lead me to this

https://community.hortonworks.com/questions/17201/registered-version-hdp-2340-is-not-listed.html?pag...

and this

https://issues.apache.org/jira/browse/AMBARI-15893

Is that what you were talking about ?

My VMs are snapshoted, so I guess I can try some things :).

Highlighted

Re: Stack upgrade using Ambari - Missing version ?

Yes, indeed, you've identified the issues I was thinking about. I'd definately suggest rolling back the snapshots and seeing if you can repeat the situation.

I once had a room full of 40 people, with one cluster per 2 people, and a slightly iffy wifi connection, we probably saw this occur on 3 of the 20 clusters, so I know the issue is out there :o/

Highlighted

Re: Stack upgrade using Ambari - Missing version ?

New Contributor

Okay I will try to roll back first ! It can be an issue with the fact I'm using a remote desktop browser's to acces ambari. I am confident, your experience will lead my small test cluster to a brighter future. Will report back there when I have some results :).

Highlighted

Re: Stack upgrade using Ambari - Missing version ?

New Contributor

Well. I can repeat the situation. I just have to add the reposytories after the rollbacks. I will try the "database tricks" option

Highlighted

Re: Stack upgrade using Ambari - Missing version ?

New Contributor

Hi,

Sorry to answer this late but this did the trick. :

https://community.hortonworks.com/answers/25787/view.html

View solution in original post

Highlighted

Re: Stack upgrade using Ambari - Missing version ?

Glad that issue is resolved.

Don't have an account?
Coming from Hortonworks? Activate your account here