Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Start service OR Add new service through Ambari fails with below excpetion. Starting services from Hosts work perfectly

Start service OR Add new service through Ambari fails with below excpetion. Starting services from Hosts work perfectly

New Contributor

Below is the error. This happens each time when i try to start all the services through "Actions" . But services starts up if i start them navigating to HOSTS.

Main problem is when I want to add a new service (like Kafka, oozie). I get same error and I haven't found a solution yet.

Services got installed without any issues during cluster creation.

  File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-INSTALL/scripts/hook.py", line 37, in <module>
    BeforeInstallHook().execute()
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py", line 280, in execute
    method(env)
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-INSTALL/scripts/hook.py", line 33, in hook
    install_repos()
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-INSTALL/scripts/repo_initialization.py", line 66, in install_repos
    _alter_repo("create", params.repo_info, template)
  File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-INSTALL/scripts/repo_initialization.py", line 33, in _alter_repo
    repo_dicts = json.loads(repo_string)
  File "/usr/lib/python2.6/site-packages/ambari_simplejson/__init__.py", line 307, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.6/site-packages/ambari_simplejson/decoder.py", line 335, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.6/site-packages/ambari_simplejson/decoder.py", line 353, in raw_decode
    raise ValueError("No JSON object could be decoded")
ValueError: No JSON object could be decoded
3 REPLIES 3
Highlighted

Re: Start service OR Add new service through Ambari fails with below excpetion. Starting services from Hosts work perfectly

New Contributor

HDP version 2.52.

Ambari 2.4

OS: RHEL 7

Re: Start service OR Add new service through Ambari fails with below excpetion. Starting services from Hosts work perfectly

Super Guru
@Vinay MP

If you are using Ranger and changed admin password recently, please try below method:

If the password was indeed changed in the Ranger Web Client but not in Ambari, then:

1) Log in to the Ambari UI.

2) Select Ranger Service.

3) Goto Configs for Ranger server.

4) Find admin_password parameter in Advanced ranger-env section.

5) Update the password to match what was entered in the Ranger Web Interface.

6) Save the settings, restart the Ranger service, then restart any services that were failing.

Re: Start service OR Add new service through Ambari fails with below excpetion. Starting services from Hosts work perfectly

New Contributor

Hey @Kuldeep Kulkarni I haven't installed Ranger.