Support Questions
Find answers, ask questions, and share your expertise

Starting ambari cluster fails during vagrant provision

Explorer

While performing vagrant provision I am getting the below error.

TASK [ambari_config : Start the ambari cluster - no wait] **********************
fatal: [node1]: FAILED! => {"changed": false, "failed": true, "msg": "Ambari client exception occurred: Coud not set cluster state: request code 500, request message {\n \"status\" : 500,\n \"message\" : \"org.apache.ambari.server.controller.spi.SystemException: An internal system exception occurred: Invalid transition for servicecomponenthost, clusterName=metron_cluster, clusterId=2, serviceName=MAPREDUCE2, componentName=HISTORYSERVER, hostname=node1, currentState=INSTALL_FAILED, newDesiredState=STARTED\"\n}"}
PLAY RECAP *********************************************************************
node1 : ok=38 changed=6 unreachable=0 failed=1
Ansible failed to complete successfully. Any error output should be visible above. Please fix these errors and try again.
4 REPLIES 4

Re: Starting ambari cluster fails during vagrant provision

can you please confirm your ambari server repository version. It sounds like you might have the old repository.

Re: Starting ambari cluster fails during vagrant provision

New Contributor

When I try to deploy in Ambari installation wizard getting the following error:

org.apache.ambari.server.controller.spi.SystemException: An internal system exception occurred: Config group not found, clusterName = infa_hdp_cluster, groupId = 1481221951741

Any light on this issue is greatly appreciated !!

,

I have been using HDP2.5 when I try to deploy in Ambari cluster installation wizard its getting failed with the following exceptions.

org.apache.ambari.server.controller.spi.SystemException: An internal system exception occurred: Config group not found, clusterName = infa_hdp_cluster, groupId = 1481221951741

Re: Starting ambari cluster fails during vagrant provision

Explorer

@Baban Gaigole

hi,have you fixed this problem?i also get this error

Re: Starting ambari cluster fails during vagrant provision

New Contributor

Nope, Instead of HDP 2.5 I have gone with HDP 2.4 which looks for more stable.