Support Questions
Find answers, ask questions, and share your expertise

Starting services takes a long time.

New Contributor

I recently installed HDP 2.6 after uninstalling HDP 2.5.

Starting and restarting services takes a long time now. Is this expected behavior?

The issue may be related to this warning:

2017-04-30 02:40:36,700 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
2017-04-30 02:40:36,871 - Stack Feature Version Info: stack_version=2.6, version=2.6.0.3-8, current_cluster_version=2.6.0.3-8 -> 2.6.0.3-8
2017-04-30 02:40:36,877 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
User Group mapping (user_group) is missing in the hostLevelParams
2017-04-30 02:40:36,878 - Group['livy'] {}
2017-04-30 02:40:36,880 - Group['spark'] {}
2017-04-30 02:40:36,880 - Group['zeppelin'] {}
2017-04-30 02:40:36,880 - Group['hadoop'] {}
2017-04-30 02:40:36,880 - Group['users'] {}
2017-04-30 02:40:36,880 - Group['knox'] {}
2017-04-30 02:40:36,881 - User['hive'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:41:08,607 - User['infra-solr'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:41:13,632 - User['atlas'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:41:21,009 - User['ams'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:41:28,278 - User['falcon'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'users']}
2017-04-30 02:41:33,581 - User['spark'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:41:38,941 - User['flume'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:41:44,226 - User['hbase'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:41:49,480 - User['hcat'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:41:54,745 - User['storm'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:41:59,860 - User['zookeeper'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:42:05,010 - User['oozie'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'users']}
2017-04-30 02:42:09,920 - User['tez'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'users']}
2017-04-30 02:42:17,235 - User['zeppelin'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'zeppelin', u'hadoop']}
2017-04-30 02:42:24,535 - User['logsearch'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:42:29,572 - User['mahout'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:42:34,672 - User['livy'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:42:41,992 - User['druid'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:42:49,261 - User['ambari-qa'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'users']}
2017-04-30 02:42:56,498 - User['kafka'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:43:04,030 - User['hdfs'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:43:11,350 - User['sqoop'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:43:17,751 - User['yarn'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:43:24,765 - User['mapred'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
2017-04-30 02:43:32,009 - User['knox'] {'gid': 'hadoop', 'fetch_nonlocal_groups': True, 'groups': [u'hadoop']}
1 ACCEPTED SOLUTION

Super Mentor

@Michael Londeen

Are you using ActiveDirectory or LDAP in your setup?

Can you please try setting the "ignore_groupsusers_create" parameter value to "true" and then ry restarting the services again?

Example:

# /var/lib/ambari-server/resources/scripts/configs.sh set  <AMBARI_FQDN> <CLUSTER_NAME> cluster-env  "ignore_groupsusers_create"  "true" 

It will made it skip users and groups creating part. Basically enabling this flag, user have to create users/groups on his own, So Ambari will not attempt to create the hadoop group for you and expected the group exists.

.

View solution in original post

3 REPLIES 3

Super Mentor

@Michael Londeen

Are you using ActiveDirectory or LDAP in your setup?

Can you please try setting the "ignore_groupsusers_create" parameter value to "true" and then ry restarting the services again?

Example:

# /var/lib/ambari-server/resources/scripts/configs.sh set  <AMBARI_FQDN> <CLUSTER_NAME> cluster-env  "ignore_groupsusers_create"  "true" 

It will made it skip users and groups creating part. Basically enabling this flag, user have to create users/groups on his own, So Ambari will not attempt to create the hadoop group for you and expected the group exists.

.

New Contributor

Neither AD or LDAP. Local users/groups only.

Super Collaborator

Is there a way to do this on a per-server basis?

I have some edge nodes where restarting services doesn't seem to work and I get this error....

; ;