Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Steps to install HDF 3.2 over HDP2.6

Steps to install HDF 3.2 over HDP2.6

Hi All,

Could anybody please let me know the steps to install HDF 3.2 over HDP 2.6.

I am using hdp 2.6..

Do i need to install the whole cluster or just to install hdf mpach 3.2 ?

Please clarify

8 REPLIES 8
Highlighted

Re: Steps to install HDF 3.2 over HDP2.6

Hi @Vishal Bohra,

As per website : https://supportmatrix.hortonworks.com/

HDF-3.2 is only supported in ambari-2.7+ versions which insupport only HDP-3.+ versions.

so its not possible to install hdf-3.2 in ambari-2.6.x versions.

Please consider upgrading your HDP and ambari if you definitely want to use hdf-3.2.

for HDF in HDP you can refer to the following guide : https://docs.hortonworks.com/HDPDocuments/HDF3/HDF-3.1.2/bk_installing-hdf-on-hdp/index.html

Please make sure product compatability is assured via website : https://supportmatrix.hortonworks.com/

Please login and accept this answer if its helpful to you.

Highlighted

Re: Steps to install HDF 3.2 over HDP2.6

@Vishal Bohra,

see if this answer helps you

Highlighted

Re: Steps to install HDF 3.2 over HDP2.6

Highlighted

Re: Steps to install HDF 3.2 over HDP2.6

Thanks for the reply...

I am geeting the error while installing hdf-ambari-mpack-3.1.2.0-7.tar.gz.tar

[root@lhdcsi02v ~]# /usr/sbin/ambari-server install-mpack --mpack=/tmp/hdf-ambari-mpack-3.1.2.0-7.tar.gz.tar --purge --verbose

Using python /usr/bin/python

Installing management pack

INFO: Loading properties from /etc/ambari-server/conf/ambari.properties

INFO: Installing management pack /tmp/hdf-ambari-mpack-3.1.2.0-7.tar.gz.tar

INFO: Loading properties from /etc/ambari-server/conf/ambari.properties

INFO: Download management pack to temp location /var/lib/ambari-server/data/tmp/hdf-ambari-mpack-3.1.2.0-7.tar.gz.tar

INFO: Loading properties from /etc/ambari-server/conf/ambari.properties

Traceback (most recent call last):

File "/usr/sbin/ambari-server.py", line 952, in <module>

mainBody()

File "/usr/sbin/ambari-server.py", line 922, in mainBody

main(options, args, parser)

File "/usr/sbin/ambari-server.py", line 874, in main

action_obj.execute()

File "/usr/sbin/ambari-server.py", line 78, in execute

self.fn(*self.args, **self.kwargs)

File "/usr/lib/ambari-server/lib/ambari_server/setupMpacks.py", line 896, in install_mpack

(mpack_metadata, mpack_name, mpack_version, mpack_staging_dir, mpack_archive_path) = _install_mpack(options, replay_mode)

File "/usr/lib/ambari-server/lib/ambari_server/setupMpacks.py", line 697, in _install_mpack

tmp_root_dir = expand_mpack(tmp_archive_path)

File "/usr/lib/ambari-server/lib/ambari_server/setupMpacks.py", line 150, in expand_mpack

archive_root_dir = get_archive_root_dir(archive_path)

File "/usr/lib/ambari-server/lib/resource_management/libraries/functions/tar_archive.py", line 85, in get_archive_root_dir

if archive.endswith('.tar.gz') or path.endswith('.tgz'):

NameError: global name 'path' is not defined

[root@lhdcsi02v ~]

Highlighted

Re: Steps to install HDF 3.2 over HDP2.6

HDF 3.2 is not compatible for  HDP2.6.5 so i have donwnload HDF 3.1 mpack but still getting the above error.
Highlighted

Re: Steps to install HDF 3.2 over HDP2.6

Hey @Vishal Bohra,

Are you able to resolve the issue,

Can you please close this thread by accepting the best answer and start a new thread explaining the issue you are facing in a new thread

probably you might not be running the command correctly.as per this docs : https://docs.hortonworks.com/HDPDocuments/HDF3/HDF-3.1.2/bk_installing-hdf-and-hdp-ppc/content/ch_in...

The command is :

ambari-server install-mpack \
--mpack=/tmp/hdf-ambari-mpack-<version>.tar.gz \
--verbose

but i see you have installed like :

usr/sbin/ambari-server install-mpack --mpack=/tmp/hdf-ambari-mpack-3.1.2.0-7.tar.gz.tar  --verbose

the package name is having some issues.

Please login and accept answer if its helpful

Highlighted

Re: Steps to install HDF 3.2 over HDP2.6

Mentor

@Vishal Bohra

When you are installing HDF to an existing cluster see steps below you can practically copy and paste. As you are running a 2.6 HDP cluster, you can just the HDF compatible with your HDP cluster using the HW matrix which gives you HDF 3.1.2 the installation procedure is outlined here.
To download the compatible HDF 3.1.2 see this download link choose the one that matches your OS ! Ensure you have setup the databases !!

Steps to install the HDF Management Pack on an HDP Cluster

############################################################## 
# stop the ambari server  
##########################
 # ambari-server stop

########################################
# Back up your Ambari resources folder
########################################
# cp -r /var/lib/ambari-server/resources /var/lib/ambari-server/resources.backup

##############################
# Release notes for the management pack
##############################
https://docs.hortonworks.com/HDPDocuments/HDF3/HDF-3.1.2/bk_release-notes/content/ch_hdf_relnotes.ht...


#######################
# On the Ambari host
######################
cd /tmp
wget -nv http://public-repo-1.hortonworks.com/HDF/centos7/3.x/updates/3.1.2.0/tars/hdf_ambari_mp/hdf-ambari-m...

#########################
# Install the mpack
#########################
# ambari-server install-mpack --mpack=/tmp/hdf-ambari-mpack-3.1.2.0-7.tar.gz --purge --verbose

#####################
# Correct output
#####################
ambari-server install-mpack --mpack=/tmp/hdf-ambari-mpack-3.1.2.0-7.tar.gz
The following will be the output:
Using python /usr/bin/python
Installing management pack
Ambari Server 'install-mpack' completed successfully.

#########################
# Restart Ambari server
########################
# ambari-server start

#############################
# On the Ambari UI
#############################
Navigate to add service and proceed with the desired options :-)

HTH

Highlighted

Re: Steps to install HDF 3.2 over HDP2.6

Still its not installing.

[root@lhdcsi02v ~]# ambari-server install-mpack --mpack=/tmp/hdf-ambari-mpack-3.1.2.0-7.tar.gz --purge --verbose
Using python /usr/bin/python
Installing management pack
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Installing management pack /tmp/hdf-ambari-mpack-3.1.2.0-7.tar.gz
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Download management pack to temp location /var/lib/ambari-server/data/tmp/hdf-ambari-mpack-3.1.2.0-7.tar.gz
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Expand management pack at temp location /var/lib/ambari-server/data/tmp/hdf-ambari-mpack-3.1.2.0-7/
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: AMBARI_SERVER_LIB is not set, using default /usr/lib/ambari-server
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: about to run command: /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.181-3.b13.el7_5.x86_64/jre/bin/java -cp '/etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/share/java/mysql-connector-java.jar' org.apache.ambari.server.checks.MpackInstallChecker --mpack-stacks HDF

INFO:
process_pid=9492
ERROR: This Ambari instance is already managing the cluster pruuk_cluster that has the HDP-2.6 stack installed on it. The management pack you are attempting to install only contains stack definitions for [HDF]. Since this management pack does not contain a stack that has already being deployed by Ambari, the --purge option would cause your existing Ambari installation to be unusable. Due to that we cannot install this management pack.

Mpack installation checker failed!

ERROR: Exiting with exit code 1.
REASON: This Ambari instance is already managing the cluster pruuk_cluster that has the HDP-2.6 stack installed on it. The management pack you are attempting to install only contains stack definitions for [HDF]. Since this management pack does not contain a stack that has already being deployed by Ambari, the --purge option would cause your existing Ambari installation to be unusable. Due to that we cannot install this management pack.

Mpack installation checker failed!

Don't have an account?
Coming from Hortonworks? Activate your account here