Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Storm Run time issues

avatar
Expert Contributor

Hi

We are hitting the below Storm Run Time errors as below:

1 ACCEPTED SOLUTION

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
6 REPLIES 6

avatar

Mostly it sounds like your upstream spouts/bolts are outpacing your downstream bolts. Try throttling your spouts with topology.max.spout.pending settings and try to increase the topology’s parallelism. Also based on your JVM profiling find out if you are GC’ing too much which can cause tuples failures. Try increasing JVM heal size (-xmx) that is allocated for each worker. You may have to use explicit G1 garbage collector. This may have negative impact as GC pause may take longer for larger heaps.

avatar
Expert Contributor
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar

I do see lot of conflicting GC arguments. Can you please try with Xmx 2048 only and remove all the exlicit GC arguments first. Then you need to tune the topology.max.spout.pending parameter with some trial and error to find the correct value.

avatar
Expert Contributor

Alright @milind pandit will try it. Thanks!

avatar

Are you able to try it out?

avatar
Expert Contributor

@milind pandit

I see topology.max.spout.pending