Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Syslog > Flume > SolrHue

Highlighted

Syslog > Flume > SolrHue

New Contributor

I am trying to pipe syslog message from flume to solr/hue. All conf file is directly edited on CM 5.5

 

I am not able to recevied anything at UI of hue.

 

Current setup is I have a kiwi syslog generator to pipe random text to a server that flume is installed. From kiwi syslog generator to flume the flow if fine.

 

I have having issue with sending from flume to solr/hue.

 

Configuration for flume (Flume > Configuration > Agent Default Group) is as follows:
agent.sources = source1
agent.sinks = sink1

agent.channels = channel1

 

agent.sources.source1.type = syslogtcp

agent.sources.source1.host = 192.168.181.192

agent.sources.source1.port = 10515

agent.sources.source1.channels = channel1

 

agent.sinks.sink1.type = org.apache.flume.sink.solr.morphline.MorphlineSolrSink

agent.sinks.sink1.channel = channel1

agent.sinks.sink1.morphlineFile = morphline.conf

 

agent.channels.channel1.type = memory

 

Configuration for morphline (Flume > Configuration > Agent Default Group > Flume-NG Solr Sink) is as follows:

SOLR_LOCATOR: {

     collection : collection1

     zkHost : "192.168.181.208:2181/solr"

}

 

morphlines: [

{

     id : morphline1

     importCommands : ["com.cloudera.**", "org.apache.solr.**"]

 

     commands : [

          {

               readLine {

                    charset : UTF-8

               }

          }

 

          {

               loadSolr {

                    solrLocator : $(SOLR_LOCATOR)

                     }

          } 

     ]

}

]

 

Any help will is greatly appreciated!