Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

TEZ View- Queries tab doesn't show any query, though DAG is available. (After configuring http authentication with SPNEGO/Kerberos)

Solved Go to solution

TEZ View- Queries tab doesn't show any query, though DAG is available. (After configuring http authentication with SPNEGO/Kerberos)

Expert Contributor

Hi,

I set up Ambari-server security https://docs.hortonworks.com/HDPDocuments/Ambari-2.1.2.1/bk_Ambari_Security_Guide/content/_configuri...

And followed https://docs.hortonworks.com/HDPDocuments/Ambari-2.1.2.1/bk_ambari_views_guide/content/section_kerbe... for setting up Tez view with Kerberos.

However, I'm not seeing any data in query tab anymore, though the same query gets listed in DAGs and all information is available there.

Before setting up my cluster for Kerberos, I saw the query tab populated with old/new queries.

Does someone know why this may be happening?

Thanks

screen-shot-2017-08-11-at-45052-pm.png

screen-shot-2017-08-11-at-45032-pm.png

screen-shot-2017-08-11-at-45121-pm.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: TEZ View- Queries tab doesn't show any query, though DAG is available. (After configuring http authentication with SPNEGO/Kerberos)

@tsharma Please check this:

This is the default ACL:

27430-picture1.png


This right now has only 3 users dr.who,activity_analyzer,yarn.

And user logged in to Ambari is “admin”. Now it says “No records available!”

27432-picture2.png

This is because, there are no jobs which are run by ‘admin’ user yet.

Say you have a user hr1, who also runs the job in the cluster. When I log into Ambari as hr1 user, I can see the jobs only for hr1:

27433-picture3.png

Now I added “admin” user into yarn.admin.acl:

27434-picture4.png

Then I can see all the jobs run by all the users:

27435-picture5.png

If you want the users who login into Ambari but do not run any jobs in the cluster to see the queries here, either add that user in “yarn.admin.acl” or set it to “*”

3 REPLIES 3

Re: TEZ View- Queries tab doesn't show any query, though DAG is available. (After configuring http authentication with SPNEGO/Kerberos)

@tsharma Please check this:

This is the default ACL:

27430-picture1.png


This right now has only 3 users dr.who,activity_analyzer,yarn.

And user logged in to Ambari is “admin”. Now it says “No records available!”

27432-picture2.png

This is because, there are no jobs which are run by ‘admin’ user yet.

Say you have a user hr1, who also runs the job in the cluster. When I log into Ambari as hr1 user, I can see the jobs only for hr1:

27433-picture3.png

Now I added “admin” user into yarn.admin.acl:

27434-picture4.png

Then I can see all the jobs run by all the users:

27435-picture5.png

If you want the users who login into Ambari but do not run any jobs in the cluster to see the queries here, either add that user in “yarn.admin.acl” or set it to “*”

Re: TEZ View- Queries tab doesn't show any query, though DAG is available. (After configuring http authentication with SPNEGO/Kerberos)

Expert Contributor

@Mugdha

One more thing, I was seeing the config versions for YARN, and in v1 (just after installation), yarn.acl.enable is set to false.

Is this property set to true while Kerberizing?

Highlighted

Re: TEZ View- Queries tab doesn't show any query, though DAG is available. (After configuring http authentication with SPNEGO/Kerberos)

@tsharma In my cluster I do see that after enabling Kerberos yarn.acl.enable was set to true. I am not sure though..

Don't have an account?
Coming from Hortonworks? Activate your account here