Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

The Stacks and versions of Ambari doesn't match rpm package

Solved Go to solution
Highlighted

The Stacks and versions of Ambari doesn't match rpm package

New Contributor

Hello all:

I'm using Ambari2.7.3.0 and HDP3.1.0.0-78 to bulid a cluster.HDP repository was build on internal network,using http://public-repo-1.hortonworks.com/HDP/centos7/3.x/updates/3.1.0.0/HDP-3.1.0.0-centos7-rpm.tar.gz ; and Ambari was downloaded from public repository .I installed Hadoop from Ambari.

Here's the problem :The version of Hadoop was completely same as HDP3.0,not HDP3.1,Could anyone tell me why?

Such as Kafka ,version is 1.0 in HDP3.0,but 2.0 in HDP3.1,rpm package version from yum repository is 2.0,I'm confused ...

97408-version.png

97407-stack.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: The Stacks and versions of Ambari doesn't match rpm package

Hi @Henry Luo ,

This will usually happen if you are using a local repository to install the HDP and ambari cannot fetch the version information from : http://public-repo-1.hortonworks.com/HDP/amazonlinux2/3.x/updates/3.1.0.0/HDP-3.1.0.0-78.xml

and instead it fetch's from stacks defined in /var/lib/ambari-server/resources

and this HDP-3.1 is minor version of HDP-3.x the stacks defined in abouve location will be having the HDP-3.0's versions information.

you can either ignore displayed versions in stacks and versions page.

or

you can go to ambari database and edit the repo_version table using following commands

[root@asn1 ~]# psql -U ambari ambari
Password for user ambari:
psql (9.2.24)
Type "help" for help.
ambari=> select version_xml from repo_version;
                                                            version_xml
-----------------------------------------------------------------------------------------------------------------------------------
 <?xml version="1.0" encoding="UTF-8" standalone="yes"?>                                              
.....<SOME DATA>... '
ambari=> update repo_version set version_xml='<USE_SAME_DATA_ABOUVE_EDIT The versions of Services as per this url : http://public-repo-1.hortonworks.com/HDP/amazonlinux2/3.x/updates/3.1.0.0/HDP-3.1.0.0-78.xml>';

Please note : always take a Database backup before any operation to ambari and stop ambari server.

Default password of database if postgresql is bigdata


PS: Please accept this answer if you find it helpful and only perform Database operations if you have prior experience or as mentioned please ignore what ambari show's in stack and versions page.



4 REPLIES 4

Re: The Stacks and versions of Ambari doesn't match rpm package

Hi @Henry Luo ,

This will usually happen if you are using a local repository to install the HDP and ambari cannot fetch the version information from : http://public-repo-1.hortonworks.com/HDP/amazonlinux2/3.x/updates/3.1.0.0/HDP-3.1.0.0-78.xml

and instead it fetch's from stacks defined in /var/lib/ambari-server/resources

and this HDP-3.1 is minor version of HDP-3.x the stacks defined in abouve location will be having the HDP-3.0's versions information.

you can either ignore displayed versions in stacks and versions page.

or

you can go to ambari database and edit the repo_version table using following commands

[root@asn1 ~]# psql -U ambari ambari
Password for user ambari:
psql (9.2.24)
Type "help" for help.
ambari=> select version_xml from repo_version;
                                                            version_xml
-----------------------------------------------------------------------------------------------------------------------------------
 <?xml version="1.0" encoding="UTF-8" standalone="yes"?>                                              
.....<SOME DATA>... '
ambari=> update repo_version set version_xml='<USE_SAME_DATA_ABOUVE_EDIT The versions of Services as per this url : http://public-repo-1.hortonworks.com/HDP/amazonlinux2/3.x/updates/3.1.0.0/HDP-3.1.0.0-78.xml>';

Please note : always take a Database backup before any operation to ambari and stop ambari server.

Default password of database if postgresql is bigdata


PS: Please accept this answer if you find it helpful and only perform Database operations if you have prior experience or as mentioned please ignore what ambari show's in stack and versions page.



Re: The Stacks and versions of Ambari doesn't match rpm package

Hi @Henry Luo,

Can you please see if this helps you.

Can you please login and accept the anwer if it did.

Re: The Stacks and versions of Ambari doesn't match rpm package

New Contributor

Sorry im late

I followed your guide and I found the version info in table "repo_version " was same as HDP3.1,and HDP.xml and HDP-UTILS.xml in my local repositories was modified to local download url,cound you give me a little more guide?Thank you very much!!

Re: The Stacks and versions of Ambari doesn't match rpm package

Hey @Henry Luo ,

As i specified earlier, we need to fetch the version_xml from repo_version table, modify it and update the table. you can use any of UI tools like PGADMIN4(if postgres UI) or can update the same using the command I mentioned above.

If you are not fully aware of Database operations you can ignore these wrong versions change as I explained above why its happening.

Hope this helps.Please accept answer if it did.