Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

The application won't work without a running HiveServer2.

Highlighted

The application won't work without a running HiveServer2.

New Contributor

Hi,

 

I am on cloudera VM 5.7.0-0 and I am facing issue with starting Hive- both in Hue and in terminal. It was working fine till last week and now I am getting following message

Screen Shot 2016-08-07 at 1.07.26 PM.png

 

As you can see, I tried restarting hiver-server2 service as well as hive-metastore. I also tried solutions mentioned in other forum where user installed cyrus system libs using "yum –y install cyrus-sasl-plain cyrus-sasl-gssapi" but

I get following -

 

Screen Shot 2016-08-07 at 1.29.46 PM.png

 

Only way I could get it work one time was by completely removing VM and re-installing it. Does anyone know what can be done to permannantely fix this issue?

 

Thank you for any help.

 

2 REPLIES 2

Re: The application won't work without a running HiveServer2.

Master Collaborator
I would check the logs in /var/log/hive to see why it's failing. Hue just
checks if it can cannot to Hive and warns you if it can't. But restarting
Hive or installing SASL libraries wouldn't necessarily address the reason
Hive is having trouble starting up - it could be a different problem in a
service Hive depends on.

Re: The application won't work without a running HiveServer2.

New Contributor

yum -y install cyrus-sasl-plain cyrus-sasl-gssapi

please check the "-" in this command.