Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

The data directory was initialized by PostgreSQL version 9.1, which is not compatible

The data directory was initialized by PostgreSQL version 9.1, which is not compatible

Explorer

Hey All,

 

We are receiving the following message when trying to start up the cloudera services (starting from cloudera-scm-server-db) This is the message we get when trying to start the DB:

 

LOG: skipping missing configuration file "/var/lib/cloudera-scm-server-db/data/postgresql.auto.conf"
FATAL: database files are incompatible with server
DETAIL: The data directory was initialized by PostgreSQL version 9.1, which is not compatible with this version 9.4.4.

How can we solve this?  We turned off Postgres 9.4.1 and only left 9.1 running.  Still no luck in getting Cloudera Manager started.

Cheers,

1 REPLY 1

Re: The data directory was initialized by PostgreSQL version 9.1, which is not compatible

Explorer

This is resolved.  The server had /usr/bin/psql point to the 9.4.4 executable instead of the 9.1 executable for another application that needed 9.4.4.  We simply pointed it to 9.1 and this resolved the above.

 

Cheers,