Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

The error of installing Spark client

The error of installing Spark client

New Contributor

I have tried to install Spark client with Ambari.

However, I have faced into the below errors.

File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 303, in _call
raise ExecutionFailed(err_msg, code, out, err)
resource_management.core.exceptions.ExecutionFailed: Execution of '/usr/bin/yum -d 0 -e 0 -y install spark2_2_6_4_0_91' returned 1. Error: Package: glibc-headers-2.17-196.el7.x86_64 (centos74)
Requires: glibc = 2.17-196.el7
Installed: glibc-2.17-222.el7.x86_64 (installed)
glibc = 2.17-222.el7
Available: glibc-2.17-196.el7.x86_64 (centos74)
glibc = 2.17-196.el7
Error: Package: glibc-devel-2.17-196.el7.x86_64 (centos74)
Requires: glibc = 2.17-196.el7
Installed: glibc-2.17-222.el7.x86_64 (installed)
glibc = 2.17-222.el7
Available: glibc-2.17-196.el7.x86_64 (centos74)
glibc = 2.17-196.el7
Error: Package: pciutils-3.5.1-2.el7.x86_64 (centos74)
Requires: pciutils-libs = 3.5.1-2.el7
Installed: pciutils-libs-3.5.1-3.el7.x86_64 (installed)
pciutils-libs = 3.5.1-3.el7
Available: pciutils-libs-3.5.1-2.el7.x86_64 (centos74)
pciutils-libs = 3.5.1-2.el7
Error: Package: libdb-devel-5.3.21-20.el7.x86_64 (centos74)
Requires: libdb(x86-64) = 5.3.21-20.el7
Installed: libdb-5.3.21-24.el7.x86_64 (installed)
libdb(x86-64) = 5.3.21-24.el7
Available: libdb-5.3.21-20.el7.x86_64 (centos74)
libdb(x86-64) = 5.3.21-20.el7

I thought that error was difference of the version which was glibc, pcutils-libs and libdb.

So, I would have downgraded the version but It was not available.

If you have information, please give me that.

Regards,

2 REPLIES 2

Re: The error of installing Spark client

@Hiroshi Shidara

The installed packages are newer than the CentOS 7.4 packages being requested. Are you on CentOS 7.5 by chance? 7.5 is not supported, only up to 7.4. You’ll need to downgrade your nodes to CentOS 7.4 and try the installation again.

Re: The error of installing Spark client

New Contributor

@emaxwell

Really Thank you for replying.
I got it. I will get ready with CentOS 7.4 and try to install that.
Regards,