Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

The installation process is right?

The installation process is right?

New Contributor

I trying to install CHD5for  the first time. I just want to make sure my process is right,  I see some wrong message in my installation process.  The following :

 

1. create a file called Cloudera-Cdh5.repo:

[root@AY1312280620257702e0Z software]# cd /etc/yum.repos.d/
[root@AY1312280620257702e0Z yum.repos.d]# ls
CentOS-Base.repo      CentOS-Debuginfo.repo  CentOS-Vault.repo
CentOS-Base.repo_bak  CentOS-Media.repo      google-chrome.repo
[
[root@AY1312280620257702e0Z yum.repos.d]# touch Cloud-Cdh5.repo
[root@AY1312280620257702e0Z yum.repos.d]# 
[root@AY1312280620257702e0Z yum.repos.d]# 
[root@AY1312280620257702e0Z yum.repos.d]# mv Cloud-Cdh5.repo C
CentOS-Base.repo       CentOS-Debuginfo.repo  CentOS-Vault.repo      
CentOS-Base.repo_bak   CentOS-Media.repo      Cloud-Cdh5.repo        
[root@AY1312280620257702e0Z yum.repos.d]# mv Cloud-Cdh5.repo Cloudera-Cdh5.repo

 

[root@AY1312280620257702e0Z software]# cat /etc/yum.repos.d/Cloudera-Cdh5.repo 
[cloudera-cdh5]
# Packages for Cloudera's Distribution for Hadoop, Version 5, on RedHat	or CentOS 6 x86_64
name=Cloudera's Distribution for Hadoop, Version 5
baseurl=http://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/5/
gpgkey = http://archive.cloudera.com/cdh5/redhat/6/x86_64/cdh/RPM-GPG-KEY-cloudera    
gpgcheck = 1

 

2. run the yum command, I see some error informaution. Is it normal:

[root@AY1312280620257702e0Z software]# sudo yum --nogpgcheck localinstall cloudera-cdh-5-0.x86_64.rpm
Loaded plugins: fastestmirror, refresh-packagekit
Setting up Local Package Process
Examining cloudera-cdh-5-0.x86_64.rpm: cloudera-cdh-5-0.x86_64
Marking cloudera-cdh-5-0.x86_64.rpm to be installed
Determining fastest mirrors
 * base: mirror.esocc.com
 * extras: mirror.esocc.com
 * updates: mirrors.163.com
base                                                                                       | 3.7 kB     00:00     
chromium-el6                                                                               | 1.9 kB     00:00     
cloudera-cdh5                                                                              |  951 B     00:00     
cloudera-cdh5/primary                                                                      |  35 kB     00:05     
cloudera-cdh5                                                                                             124/124
extras                                                                                     | 3.4 kB     00:00     
updates                                                                                    | 3.4 kB     00:00     
updates/primary_db                                                                         | 1.4 MB     00:00     
Resolving Dependencies
--> Running transaction check
---> Package cloudera-cdh.x86_64 0:5-0 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================
 Package                    Arch                 Version             Repository                              Size
==================================================================================================================
Installing:
 cloudera-cdh               x86_64               5-0                 /cloudera-cdh-5-0.x86_64                13 k

Transaction Summary
==================================================================================================================
Install       1 Package(s)

Total size: 13 k
Installed size: 13 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : cloudera-cdh-5-0.x86_64                                                                        1/1 
ERROR:dbus.proxies:Introspect error on :1.32:/org/freedesktop/PackageKit: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Unable to send message to PackageKit
  Verifying  : cloudera-cdh-5-0.x86_64                                                                        1/1 

Installed:
  cloudera-cdh.x86_64 0:5-0                                                                                       

Complete!
[root@AY1312280620257702e0Z software]# 

 

1 REPLY 1

Is it a problem when I run "sudo yum install hadoop-conf-pseudo"?

New Contributor

Is it a problem when I run "sudo yum install hadoop-conf-pseudo"?

 

 

ERROR:dbus.proxies:Introspect error on :1.32:/org/freedesktop/PackageKit: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
Unable to send message to PackageKit
Verifying : 1:perl-Module-Pluggable-3.90-136.el6.x86_64 1/75
Verifying : 4:perl-libs-5.10.1-136.el6.x86_64 2/75
Verifying : hadoop-mapreduce-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 3/75
Verifying : foomatic-db-filesystem-4.0-7.20091126.el6.noarch 4/75
Verifying : db4-cxx-4.7.25-18.el6_4.x86_64 5/75
Verifying : urw-fonts-2.4-10.el6.noarch 6/75
Verifying : redhat-lsb-4.0-7.el6.centos.x86_64 7/75
Verifying : redhat-lsb-core-4.0-7.el6.centos.x86_64 8/75
Verifying : m4-1.4.13-5.el6.x86_64 9/75
Verifying : 4:perl-5.10.1-136.el6.x86_64 10/75
Verifying : db4-devel-4.7.25-18.el6_4.x86_64 11/75
Verifying : pax-3.4-10.1.el6.x86_64 12/75
Verifying : 1:qt-4.6.2-26.el6_4.x86_64 13/75
Verifying : db4-utils-4.7.25-18.el6_4.x86_64 14/75
Verifying : hadoop-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 15/75
Verifying : at-3.1.10-43.el6_2.1.x86_64 16/75
Verifying : foomatic-db-ppds-4.0-7.20091126.el6.noarch 17/75
Verifying : hadoop-yarn-resourcemanager-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 18/75
Verifying : bigtop-utils-0.6.0+cdh5.0.0+266-0.cdh5b1.p0.44.el6.noarch 19/75
Verifying : foomatic-4.0.4-3.el6.x86_64 20/75
Verifying : hadoop-hdfs-datanode-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 21/75
Verifying : hadoop-conf-pseudo-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 22/75
Verifying : poppler-data-0.4.0-1.el6.noarch 23/75
Verifying : hadoop-hdfs-secondarynamenode-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 24/75
Verifying : qt3-3.3.8b-30.el6.x86_64 25/75
Verifying : 1:perl-Pod-Simple-3.13-136.el6.x86_64 26/75
Verifying : db4-4.7.25-18.el6_4.x86_64 27/75
Verifying : redhat-lsb-compat-4.0-7.el6.centos.x86_64 28/75
Verifying : hadoop-yarn-nodemanager-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 29/75
Verifying : perl-Test-Simple-0.92-136.el6.x86_64 30/75
Verifying : redhat-lsb-graphics-4.0-7.el6.centos.x86_64 31/75
Verifying : bc-1.06.95-1.el6.x86_64 32/75
Verifying : zookeeper-3.4.5+cdh5.0.0+25-0.cdh5b1.p0.41.el6.noarch 33/75
Verifying : gdbm-devel-1.8.0-36.el6.x86_64 34/75
Verifying : portreserve-0.0.4-9.el6.x86_64 35/75
Verifying : 1:cups-1.4.2-50.el6_4.5.x86_64 36/75
Verifying : 1:qt-x11-4.6.2-26.el6_4.x86_64 37/75
Verifying : openjpeg-libs-1.3-10.el6_5.x86_64 38/75
Verifying : hadoop-hdfs-namenode-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 39/75
Verifying : perl-Test-Harness-3.17-136.el6.x86_64 40/75
Verifying : ghostscript-fonts-5.50-23.1.el6.noarch 41/75
Verifying : 4:perl-devel-5.10.1-136.el6.x86_64 42/75
Verifying : mailx-12.4-7.el6.x86_64 43/75
Verifying : perl-ExtUtils-MakeMaker-6.55-136.el6.x86_64 44/75
Verifying : poppler-utils-0.12.4-3.el6_0.1.x86_64 45/75
Verifying : hadoop-yarn-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 46/75
Verifying : time-1.7-37.1.el6.x86_64 47/75
Verifying : nc-1.84-22.el6.x86_64 48/75
Verifying : 3:perl-version-0.77-136.el6.x86_64 49/75
Verifying : 1:perl-ExtUtils-ParseXS-2.2003.0-136.el6.x86_64 50/75
Verifying : redhat-lsb-printing-4.0-7.el6.centos.x86_64 51/75
Verifying : 1:phonon-backend-gstreamer-4.6.2-26.el6_4.x86_64 52/75
Verifying : ed-1.1-3.3.el6.x86_64 53/75
Verifying : 1:perl-Pod-Escapes-1.04-136.el6.x86_64 54/75
Verifying : ghostscript-8.70-19.el6.x86_64 55/75
Verifying : patch-2.6-6.el6.x86_64 56/75
Verifying : perl-CGI-3.51-136.el6.x86_64 57/75
Verifying : hadoop-mapreduce-historyserver-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 58/75
Verifying : bigtop-jsvc-0.6.0+cdh5.0.0+266-0.cdh5b1.p0.41.el6.x86_64 59/75
Verifying : hadoop-hdfs-2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6.x86_64 60/75
Verifying : cvs-1.11.23-16.el6.x86_64 61/75
Verifying : mesa-libGLU-9.2-0.5.el6_5.2.x86_64 62/75
Verifying : gettext-0.17-16.el6.x86_64 63/75
Verifying : poppler-0.12.4-3.el6_0.1.x86_64 64/75
Verifying : 1:qt-sqlite-4.6.2-26.el6_4.x86_64 65/75
Verifying : foomatic-db-4.0-7.20091126.el6.noarch 66/75
Verifying : libmng-1.0.10-4.1.el6.x86_64 67/75
Verifying : 1:perl-Module-Pluggable-3.90-127.el6.x86_64 68/75
Verifying : db4-4.7.25-17.el6.x86_64 69/75
Verifying : 3:perl-version-0.77-127.el6.x86_64 70/75
Verifying : 1:perl-Pod-Escapes-1.04-127.el6.x86_64 71/75
Verifying : 1:perl-Pod-Simple-3.13-127.el6.x86_64 72/75
Verifying : 4:perl-5.10.1-127.el6.x86_64 73/75
Verifying : db4-utils-4.7.25-17.el6.x86_64 74/75
Verifying : 4:perl-libs-5.10.1-127.el6.x86_64 75/75

Installed:
hadoop-conf-pseudo.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6

Dependency Installed:
at.x86_64 0:3.1.10-43.el6_2.1
bc.x86_64 0:1.06.95-1.el6
bigtop-jsvc.x86_64 0:0.6.0+cdh5.0.0+266-0.cdh5b1.p0.41.el6
bigtop-utils.noarch 0:0.6.0+cdh5.0.0+266-0.cdh5b1.p0.44.el6
cups.x86_64 1:1.4.2-50.el6_4.5
cvs.x86_64 0:1.11.23-16.el6
db4-cxx.x86_64 0:4.7.25-18.el6_4
db4-devel.x86_64 0:4.7.25-18.el6_4
ed.x86_64 0:1.1-3.3.el6
foomatic.x86_64 0:4.0.4-3.el6
foomatic-db.noarch 0:4.0-7.20091126.el6
foomatic-db-filesystem.noarch 0:4.0-7.20091126.el6
foomatic-db-ppds.noarch 0:4.0-7.20091126.el6
gdbm-devel.x86_64 0:1.8.0-36.el6
gettext.x86_64 0:0.17-16.el6
ghostscript.x86_64 0:8.70-19.el6
ghostscript-fonts.noarch 0:5.50-23.1.el6
hadoop.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6
hadoop-hdfs.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6
hadoop-hdfs-datanode.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6
hadoop-hdfs-namenode.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6
hadoop-hdfs-secondarynamenode.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6
hadoop-mapreduce.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6
hadoop-mapreduce-historyserver.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6
hadoop-yarn.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6
hadoop-yarn-nodemanager.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6
hadoop-yarn-resourcemanager.x86_64 0:2.2.0+cdh5.0.0+353-0.cdh5b1.p0.79.el6
libmng.x86_64 0:1.0.10-4.1.el6
m4.x86_64 0:1.4.13-5.el6
mailx.x86_64 0:12.4-7.el6
mesa-libGLU.x86_64 0:9.2-0.5.el6_5.2
nc.x86_64 0:1.84-22.el6
openjpeg-libs.x86_64 0:1.3-10.el6_5
patch.x86_64 0:2.6-6.el6
pax.x86_64 0:3.4-10.1.el6
perl-CGI.x86_64 0:3.51-136.el6
perl-ExtUtils-MakeMaker.x86_64 0:6.55-136.el6
perl-ExtUtils-ParseXS.x86_64 1:2.2003.0-136.el6
perl-Test-Harness.x86_64 0:3.17-136.el6
perl-Test-Simple.x86_64 0:0.92-136.el6
perl-devel.x86_64 4:5.10.1-136.el6
phonon-backend-gstreamer.x86_64 1:4.6.2-26.el6_4
poppler.x86_64 0:0.12.4-3.el6_0.1
poppler-data.noarch 0:0.4.0-1.el6
poppler-utils.x86_64 0:0.12.4-3.el6_0.1
portreserve.x86_64 0:0.0.4-9.el6
qt.x86_64 1:4.6.2-26.el6_4
qt-sqlite.x86_64 1:4.6.2-26.el6_4
qt-x11.x86_64 1:4.6.2-26.el6_4
qt3.x86_64 0:3.3.8b-30.el6
redhat-lsb.x86_64 0:4.0-7.el6.centos
redhat-lsb-compat.x86_64 0:4.0-7.el6.centos
redhat-lsb-core.x86_64 0:4.0-7.el6.centos
redhat-lsb-graphics.x86_64 0:4.0-7.el6.centos
redhat-lsb-printing.x86_64 0:4.0-7.el6.centos
time.x86_64 0:1.7-37.1.el6
urw-fonts.noarch 0:2.4-10.el6
zookeeper.noarch 0:3.4.5+cdh5.0.0+25-0.cdh5b1.p0.41.el6

Dependency Updated:
db4.x86_64 0:4.7.25-18.el6_4 db4-utils.x86_64 0:4.7.25-18.el6_4
perl.x86_64 4:5.10.1-136.el6 perl-Module-Pluggable.x86_64 1:3.90-136.el6
perl-Pod-Escapes.x86_64 1:1.04-136.el6 perl-Pod-Simple.x86_64 1:3.13-136.el6
perl-libs.x86_64 4:5.10.1-136.el6 perl-version.x86_64 3:0.77-136.el6

Complete!

Don't have an account?
Coming from Hortonworks? Activate your account here