Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

The specified resource doesn't exist: Stack data, Stack HDP 2.4.2.0

Highlighted

The specified resource doesn't exist: Stack data, Stack HDP 2.4.2.0

New Contributor

Hi

Im using lastest

local version:1.3.0 latest release:1.3.0 docker images: sequenceiq/haveged:1.1 sequenceiq/socat:1.0.0 sequenceiq/uaadb:v2.7.1 sequenceiq/uaa:2.7.1 sequenceiq/cbdb:1.3.0 sequenceiq/cloudbreak:1.3.0 hortonworks/cloudbreak-auth:1.3.0 hortonworks/cloudbreak-web:1.3.0 sequenceiq/pcdb:1.3.0 sequenceiq/periscope:1.3.0

Im getting The specified resource doesn't exist: Stack data, Stack HDP 2.4.2.0 is not found in Ambari metainfo

see below error log

2016-08-14 09:17:08,769 [reactorDispatcher-10] buildAmbariCluster:273 ^[[1;31mERROR^[[0;39m c.s.c.s.c.f.AmbariClusterConnector - [owner:spring] [type:springLog] [id:] [name:] Error while building the Ambari cluster. Message Cannot use the specified Ambari stack: AmbariStackDetails{id=5, stack='HDP', version='2.4.2.0', os='redhat7', stackRepoId='HDP-2.4.2.0', utilsRepoId='HDP-UTILS-1.1.0.20', stackBaseURL='http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0', utilsBaseURL='http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/centos7', verify=false}. Error: org.apache.ambari.server.controller.spi.NoSuchResourceException: The specified resource doesn't exist: Stack data, Stack HDP 2.4.2.0 is not found in Ambari metainfo, throwable: {} /cbreak_cloudbreak_1 | com.sequenceiq.cloudbreak.controller.BadRequestException: Cannot use the specified Ambari stack: AmbariStackDetails{id=5, stack='HDP', version='2.4.2.0', os='redhat7', stackRepoId='HDP-2.4.2.0', utilsRepoId='HDP-UTILS-1.1.0.20', stackBaseURL='http://public-repo-1.hortonworks.com/HDP/centos7/2.x/updates/2.4.2.0', utilsBaseURL='http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.20/repos/centos7', verify=false}. Error: org.apache.ambari.server.controller.spi.NoSuchResourceException: The specified resource doesn't exist: Stack data, Stack HDP 2.4.2.0 is not found in Ambari metainfo /cbreak_cloudbreak_1 | at com.sequenceiq.cloudbreak.service.cluster.flow.AmbariClusterConnector.setBaseRepoURL(AmbariClusterConnector.java:772) /cbreak_cloudbreak_1 | at com.sequenceiq.cloudbreak.service.cluster.flow.AmbariClusterConnector.buildAmbariCluster(AmbariClusterConnector.java:227) /cbreak_cloudbreak_1 | at com.sequenceiq.cloudbreak.core.cluster.AmbariClusterCreationService.buildAmbariCluster(AmbariClusterCreationService.java:27)

Thanks You

Os

3 REPLIES 3

Re: The specified resource doesn't exist: Stack data, Stack HDP 2.4.2.0

Expert Contributor

For the version you only need to specify 2.4 the rest of the stack details looks good to me.

Correction: stackRepoId should be HDP-2.4 as well

Re: The specified resource doesn't exist: Stack data, Stack HDP 2.4.2.0

New Contributor

Is there a way you can specify to install centos7 its defaulting to Amazon Linux

Re: The specified resource doesn't exist: Stack data, Stack HDP 2.4.2.0

Expert Contributor

Here's how you can use custom images with cloudbreak: http://sequenceiq.com/cloudbreak-docs/master/images/

There is no default centos 7 image for AWS although on every other platform we go with centos 7 , but in this case you need to build it for yourself.

Here's another related thread: https://community.hortonworks.com/questions/50665/how-to-bootstrap-a-custom-ami-on-aws-for-cloudbrea... he's building a redhat7 image instead of amazonlinux.