Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here. Want to know more about what has changed? Check out the Community News blog.

Transpatent Huge Page in Centos/Redhat

SOLVED Go to solution

Transpatent Huge Page in Centos/Redhat

Contributor

Hi there,

 

Whenever instaling Cloudera on Redhat 7 or Centos 7, after disabling the transparent hugepage, the warning still showing, I have already put the following lines to /etc/rc.local, however it is still the same.

 

echo never > /sys/kernel/mm/transparent_hugepage/defrag
echo never > /sys/kernel/mm/transparent_hugepage/enabled

 

I tried the following as well.

echo never > /sys/kernel/mm/redhat_transparent_hugepage/defrag
echo never > /sys/kernel/mm/redhat_transparent_hugepage/enabled

 

Thank you.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Transpatent Huge Page in Centos/Redhat

Contributor

after changing the rc.local to executable, it solved the issue

 

$chmod +x /etc/rc.d/rc.local

3 REPLIES 3

Re: Transpatent Huge Page in Centos/Redhat

Champion

what version of kernel are you using ? 

did this happens after reboot ? 

do you have permission to change the value 

Re: Transpatent Huge Page in Centos/Redhat

Contributor

Helo csguna,

 

The kernel is 3.10, after rebooted it is the same, I am using root account.

 

 

Highlighted

Re: Transpatent Huge Page in Centos/Redhat

Contributor

after changing the rc.local to executable, it solved the issue

 

$chmod +x /etc/rc.d/rc.local