Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Trouble Installing Accumulo 1.6 on CDH 5.6

Trouble Installing Accumulo 1.6 on CDH 5.6

New Contributor


We have recently installed Accumulo 1.6 on our CDH5 cluster (7 days ago) and we have not been able to get the tservers to start or the Web UI to display. I would greatly appreciate any assistance or suggestions.


CM reports that Accumulo was successfully initialized and the master, monitor, tracer, and garbage collection services are all running with no issues. The problem is that we cannot start any of the tservers. The stdout and stderr logs show no ERRORS only log4j WARNS:


log4j:WARN No appenders could be found for logger (org.apache.accumulo.start.classloader.AccumuloClassLoader).
log4j:WARN Please initialize log4j properly.
log4j:WARN See for more info.


I think we must still be experiencing issues with master and/or monitor. CM is reporting that they are healthy and running yet the master log is empty and the monitor log has not been updated since 05-06-16.


Re: Trouble Installing Accumulo 1.6 on CDH 5.6


Hey, I am having the exact same problem (except my CDH is 5.8). Have you been able to solve it?

Re: Trouble Installing Accumulo 1.6 on CDH 5.6


Same problem here with CDH 5.11 and Accumulo 1.7

Has anyone resolved this? 

Seems a very common problem with very few solutions. Surely someone has sorted this?



Re: Trouble Installing Accumulo 1.6 on CDH 5.6


Is this the problem?


Can't open /var/run/cloudera-scm-agent/process/6248-accumulo16-ACCUMULO16_MASTER/ Permission denied.

If I manually go to that directory as root and unzip the file, then the "" is unpacked.


Is the problem that there is no "" because the unzip fails?


# ls -la
total 40
drwxr-x--x   6 accumulo accumulo   300 Jul 12 08:22 .
drwxr-x--x 234 root     root      4680 Jul 12 08:06 ..
-rw-r--r--   1 root     root         0 Jul 12 08:06 accumulo16.keytab
-rw-r-----   1 accumulo accumulo  2183 Jul 12 08:06 accumulo-metrics.xml
-rw-r--r--   1 root     root       729 Jul 12 08:06 accumulo-site.xml
drwxr-x--x   3 accumulo accumulo    80 Jul 12 08:22 aux
-rw-r--r--   1 root     root       238 Jul 12 08:06
-rw-------   1 root     root     11836 Jul 12 08:06
-rw-r-----   1 accumulo accumulo  1794 Jul 12 08:06
drwxr-x--x   2 accumulo accumulo   180 Jul 12 08:22 hadoop-conf
-rw-r--r--   1 root     root       811 Jul 12 08:06
drwxr-x--x   2 accumulo accumulo    80 Jul 12 08:06 logs
-rw-------   1 root     root      2062 Jul 12 08:06 proc.json
drwxr-x--x   2 accumulo accumulo   100 Jul 12 08:22 scripts
-rw-------   1 root     root      3402 Jul 12 08:06 supervisor.conf

Re: Trouble Installing Accumulo 1.6 on CDH 5.6


Following on from the clues above, I decided to completely remove Accumulo.


I downloaded it again, distributed it again via Parcels, and then activated. I then added the service, taking all of the defaults.


All up and working now. Those errors are still there but don't seem to make any difference!


I won't mark it as a solution because I don't understand why it now works.



Re: Trouble Installing Accumulo 1.6 on CDH 5.6


My problem is indeed that there is no in the process folder but it wasn't because of an unzipping process as I see. Just this in stderr.log:


sed: can't read /var/run/cloudera-scm-agent/process/xxxx-accumulo16-ACCUMULO16_TSERVER/ No such file or directory

Then log4j warnings at the bottom.


I also tried removing all and setting up again like you did but faced the same problem. Tablet servers don't start up.

Adding "/etc/accumulo/conf" to accumulo classpath also doesn't help.


I believe I'm having a different issue but can't see it because of the logging configuration. I tried adding these properties that I found at somewhere else to Accumulo configuration on Cloudera Manager but it doesn't seem to work


Tablet Server Logging Advanced Configuration Snippet (Safety Valve):

log4j.rootLogger=INFO, logAppender, console

log4j.appender.logAppender.layout.ConversionPattern=%d [%t] %-5p %c - %m%n
log4j.appender.stdout.layout.ConversionPattern=%d{yyyy-MM-dd HH:mm:ss} %-5p %c{1}:%L - %m%n


I just couldn't figure out how I can include in the process folder when starting the Tablet Server role.

Re: Trouble Installing Accumulo 1.6 on CDH 5.6


I managed to start up the tablet servers. I checked the role log and there was an error saying block memory size is not enough so I changed it from Cloudera Manager. If anyone still has this problem, checking the role log might help.

Don't have an account?
Coming from Hortonworks? Activate your account here