Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Trying to install MADLIB 1.9.1 package on HDP 2.4 running HAWQ 2.1.1, gives the following ERROR:​

Trying to install MADLIB 1.9.1 package on HDP 2.4 running HAWQ 2.1.1, gives the following ERROR:​

New Contributor

Trying to install MADLIB 1.9.1 package (downloaded from the Pivotal site) - HDP 2.4 running HAWQ 2.1.1, gives the following ERROR:

gpadmin@sandbox hawq_2_1_1_0]$ /usr/local/hawq_2_1_1_0/madlib/bin/madpack install-check -p hawq  -c gpadmin
/gpadmin@sandbox.hortonworks.com:65432/template1
madpack.py : INFO : Detected HAWQ version 2.1.                                                   
madpack.py : ERROR : This version is not among the HAWQ versions for which MADlib support files have been installed (2.0).
4 REPLIES 4

Re: Trying to install MADLIB 1.9.1 package on HDP 2.4 running HAWQ 2.1.1, gives the following ERROR:​

New Contributor

Hi Leonard ,

Hope you are following the same installation steps that mentioned in https://cwiki.apache.org/confluence/display/MADLIB/Installation+Guide#InstallationGuide-10/7/16-Inst....Please make sure you are following the steps in the right order

So the correct order of operations is:

1. gppkg install of MADlib 2. run remove_compression.sh 3. run madpack utility

Thanks

Pratheesh Nair

Re: Trying to install MADLIB 1.9.1 package on HDP 2.4 running HAWQ 2.1.1, gives the following ERROR:​

New Contributor

Hi Pratheesh,

I ran 'remove-compression.sh' on madpack to remove the compression, successfully.

However, at the checking /creating PL/PYTHON stage, the installation fails with the following ERROR:

root@sandbox ~]# su - gpadmin                                                                 
[gpadmin@sandbox ~]$ /usr/local/hawq_2_1_1_0/madlib/bin/madpack install -s madlib -p hawq -c  gpadmin@sandbox.hortonworks.com:65432/template1
madpack.py : INFO : Detected HAWQ version 2.1.                                                 
madpack.py : INFO : *** Installing MADlib ***                                                  
madpack.py : INFO : MADlib tools version    = 1.9.1 (/usr/local/hawq_2_1_1_0/madlib/Versions/1.9.1/bin/../madpack/madpack.py)                                                               
madpack.py : INFO : MADlib database version = None (host=sandbox.hortonworks.com:65432, db=template1, schema=madlib)                                                                           
madpack.py : INFO : Testing PL/Python environment...                                           
madpack.py : ERROR : SQL command failed:                                                       
SQL: SELECT plpy_version_for_madlib() AS ver;                                                  
ERROR:  failed to acquire resource from resource manager, queued resource request is timed out due to no resource (pquery.c:804)                                                               
madpack.py : ERROR : MADlib installation failed.                                              
[gpadmin@sandbox ~]$

---- Why does it fail with a time out from resource manager ... is there any configuration that I should change, to allow the installation to complete successfully?
Many Thanks!

Re: Trying to install MADLIB 1.9.1 package on HDP 2.4 running HAWQ 2.1.1, gives the following ERROR:​

Contributor

I am able to install madlib after running remove-compression.sh script:

[gpadmin@dumst2 ~]$ /usr/local/hawq/madlib/bin/madpack install -s madlib -p hawq -c gpadmin@localhost:5432/testdb madpack.py : INFO : Detected HAWQ version 2.1. madpack.py : ERROR : This version is not among the HAWQ versions for which MADlib support files have been installed (2.0). [gpadmin@dumst2 ~]$ ls hawqAdminLogs madlib-ossv1.9.1_pv1.9.6_hawq2.1-rhel5-x86_64.tgz ReleaseNotes.txt madlib-ossv1.10.0_pv1.9.7_hawq2.1-rhel5-x86_64.tar.gz open_source_license_MADlib_1.9.1_GA.txt remove_compression.sh madlib-ossv1.9.1_pv1.9.6_hawq2.1-rhel5-x86_64.gppkg README remove_compression.txt [gpadmin@dumst2 ~]$ chmod 755 remove_compression.sh [gpadmin@dumst2 ~]$ ./remove_compression.sh Using MADlib installation path: /usr/local/hawq/./madlib patching file /usr/local/hawq/./madlib/Current/madpack/madpack.py Successfully patched necessary files [gpadmin@dumst2 ~]$ /usr/local/hawq/madlib/bin/madpack install -s madlib -p hawq -c gpadmin@localhost:5432/testdb madpack.py : INFO : Detected HAWQ version 2.1. madpack.py : INFO : *** Installing MADlib *** madpack.py : INFO : MADlib tools version = 1.9.1 (/usr/local/hawq_2_1_1_0/madlib/Versions/1.9.1/bin/../madpack/madpack.py) madpack.py : INFO : MADlib database version = None (host=localhost:5432, db=testdb, schema=madlib) madpack.py : INFO : Testing PL/Python environment... madpack.py : INFO : > Creating language PL/Python... madpack.py : INFO : > PL/Python environment OK (version: 2.6.6) madpack.py : INFO : Installing MADlib into MADLIB schema... madpack.py : INFO : > Creating MADLIB schema madpack.py : INFO : > Creating MADLIB.MigrationHistory table madpack.py : INFO : > Writing version info in MigrationHistory table madpack.py : INFO : > Creating objects for modules: madpack.py : INFO : > - array_ops madpack.py : INFO : > - bayes madpack.py : INFO : > - crf madpack.py : INFO : > - elastic_net madpack.py : INFO : > - linalg madpack.py : INFO : > - pmml madpack.py : INFO : > - prob madpack.py : INFO : > - sketch madpack.py : INFO : > - svec madpack.py : INFO : > - svm madpack.py : INFO : > - tsa madpack.py : INFO : > - stemmer madpack.py : INFO : > - conjugate_gradient madpack.py : INFO : > - lda madpack.py : INFO : > - stats madpack.py : INFO : > - svec_util madpack.py : INFO : > - utilities madpack.py : INFO : > - assoc_rules madpack.py : INFO : > - convex madpack.py : INFO : > - glm madpack.py : INFO : > - linear_systems madpack.py : INFO : > - recursive_partitioning madpack.py : INFO : > - regress madpack.py : INFO : > - sample madpack.py : INFO : > - summary madpack.py : INFO : > - kmeans madpack.py : INFO : > - pca madpack.py : INFO : > - validation madpack.py : INFO : MADlib 1.9.1 installed successfully in MADLIB schema. [gpadmin@dumst2 ~]$

Re: Trying to install MADLIB 1.9.1 package on HDP 2.4 running HAWQ 2.1.1, gives the following ERROR:​

Guru
@Leonard Edwin

@Pratheesh Nair

The problem is with the rpm packaging. When the rpm is installed, it creates a folder with this name "/usr/local/hawq/madlib/Versions/1.9.1/ports/hawq/2.0". The issue is with madlib version 1.9.1 for HDB 2.1.x. Then madpack.py tries to compare the HAWQ major version (dbver) i.e., "2.1" with the folder name created while installing "gppkg --install madlib...." and fails.

Simplest workaround would be to rename this folder to 2.1 and run it. If you are uncomfortable with the idea, just go for 1.10, that creates the appropriate folder "2.1" while running gppkg.

Don't have an account?
Coming from Hortonworks? Activate your account here