Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Tutorial Exercise 4 - Permission denied

Highlighted

Tutorial Exercise 4 - Permission denied

New Contributor

Hello,

 

While trying to create the collection in exercise 4, I'm getting this error: 

 

Unable to create core [live_logs_shard1_replica1] Caused by: Permission denied: user=solr, access=WRITE, inode="/":hdfs:supergroup:drwxr-xr-x

 

After executing the following command on a VMWare Quickstart:

 

[cloudera@quickstart flume]$ solrctl --zk quickstart:2181/solr collection --create live_logs -s 1

 

I already had a permission error during the Spark exercise 3, what am I doing wrong? 

 

Thank you

 

5 REPLIES 5

Re: Tutorial Exercise 4 - Permission denied

New Contributor
Had the same problem today. Just downloaded the quick start VM earlier this evening.

Re: Tutorial Exercise 4 - Permission denied

Same problem. Tried adding user "solr" to the supergroup but that didn't work either.

 

--Fixed by creating /user/solr in hdfs and chown the perms solr:solr in hadoop

Re: Tutorial Exercise 4 - Permission denied

New Contributor

Same problem here.

 

Tried BobBobsonIIIEsq solution, but still get the same problem.

 

Help would be really, really appreciated!

Re: Tutorial Exercise 4 - Permission denied

New Contributor

Try this:

 

The error message states the 'solr' user is denied permission to write the collection directly to root directory. If you are using Cloudera Manager, try verifying configuration settings and check the HDFS data directory path, /solr or /user/solr.

 

Capture.PNG

 

If the path is set to /solr, then use hdfs to create the directory and chown it to solr

 

bash-4.1$ hadoop fs -mkdir /solr
bash-4.1$ hadoop fs -chown -R solr:solr /solr

Thanks for the friend who showed this fix.

Re: Tutorial Exercise 4 - Permission denied

New Contributor
Thanks. I have to use "sudo -u hdfs hadoop fs -mkdir /solr" and "sudo -u hdfs hadoop fs -chown -R solr:solr /solr" to make it work.