Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Unable to Connect to 127.0.0.1:8888. None of the commands are working in Sandbox

Highlighted

Unable to Connect to 127.0.0.1:8888. None of the commands are working in Sandbox

39493-127001.png

39494-sandbox-2.png

39495-network.png

39496-sandbox-3.png

39497-127001.png

39498-network.png

Hi,

I have installed virtual box (5.1.28) and imported hortonwork sandbox (HDP_2.6_1_docker). It start ok giving 3 options (Only last one works). I can then login to sandbox with id - root and pwd - hadoop. after that none of the command work (See the screenshot). even ifconfig -a or ipconfig does not work. Also unable to access 127.0.0.1:8888 or 127.0.0.1:8080 using browser.

Tried all the solutions found online like -

1. Check port setting. It looks fine.

2. Changing the network adapter to "bridged adapter" and "Host Only Adapter". But none helped.

3. Shut of wirewall setting. It did not help either.

I am dead in the water for last few days. Please help

5 REPLIES 5
Highlighted

Re: Unable to Connect to 127.0.0.1:8888. None of the commands are working in Sandbox

Super Mentor

@Vikrant Kumar

You seems to be doing SSH to sandbox using port 22 which is not correct and hence you are not getting the path of basic commands like "ambari-server start"

.

For Sandbox SSH you must use port "2222" only while using Putty. And from other non putty based environment you can use the following command to do SSH on port 2222

# ssh root@127.0.0.1 -p 2222

.

Re: Unable to Connect to 127.0.0.1:8888. None of the commands are working in Sandbox

Thanks Jay for responding. I tried it but it says connection refused. Please see the screenshot. kindly help

40489-sandbox-4.png

Highlighted

Re: Unable to Connect to 127.0.0.1:8888. None of the commands are working in Sandbox

Super Mentor

@Vikrant Kumar

In your output we see that you are already inside the Sandbox (host) ... then why you want to do again ssh to the same sandbox ?

What i mean to say is that When you Open Putty ... then there is a option to choose the SSH port. Just specify port as 2222 there.

.

1. Try stopping the Sandbox completely (Power Off).

2. Start the Sandbox freshly

3. Open Putty and while doing SSH , specify SSH port as 2222 (instead of default 22).

4. Once you login to Sandbox host using SSH (on port 2222) then check if ambari server is running or not?

# ambari-server status

.

Highlighted

Re: Unable to Connect to 127.0.0.1:8888. None of the commands are working in Sandbox

Hi Jay,

Appreciate your help. I tried to do ssh using putty but got error. See the screenshots. Please suggest if I am doing anything wrong.

Main issue is I am not able to open 127.0.0.1:8888 or 127.0.0.1:8080 on the browser. Please help

40490-putty-1.png

40491-putty-2.png

Highlighted

Re: Unable to Connect to 127.0.0.1:8888. None of the commands are working in Sandbox

Super Mentor

@Vikrant Kumar

It simply means that your Sandbox container itself has some issues in coming up.

In your very first screenshot we see that you highlighted "CentOS Linux (0-rescue ....". Please do not choose that option and use the first option "CentOS Linux (4.12.4-1......."

And please share the screenshot of your successful Sandbox startup completion message as following (this is to confirm that your Sandbox started successfully or not?)

40492-sandbox-started.png

.

Don't have an account?
Coming from Hortonworks? Activate your account here