Support Questions
Find answers, ask questions, and share your expertise

Unable to Install Nifi to existing cluster

Explorer

I'm Unable to add HDF Package ( Nifi ) 3.0.3 to existing Cluster . Versions which I'm using HDP version 2.6.3 and Ambari 2.6.0. I'm using Cent OS 7.2.

Steps I'm following to Install:

-> Installed the M-Pack using the command ambari-server install-mpack --mpack=/tmp/hdf-ambari-mpack-<version>.tar.gz --verbose

-> ambari-server restart

-> Added Base URL for HDF 3.0.3(Local and Public repo ) and Added Base URL for HDF 3.0.2 . Both ways It failed ..

Followed the URL to install https://docs.hortonworks.com/HDPDocuments/HDF3/HDF-3.0.3/bk_installing-hdf-and-hdp-ppc/content/ch_in...

And I see this Warning You cannot install HDF 3.0.3 on systems other than IBM Power Systems. For information about the latest release on systems other than IBM Power Systems, see the HDF 3.0.2 Release Notes.

This is my local Repo file hdf.repo ( adjusted the public URL when i'm using the URL)

#VERSION_NUMBER=3.0.3.0-6
	[HDF-3.0.3.0]
	name=HDF Version - HDF-3.0.3.0
	baseurl=http://192.168.1.8/repo/HDF/
	gpgcheck=1
	gpgkey=http://public-repo-1.hortonworks.com/HDF/centos7-ppc/3.x/updates/3.0.3.0/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins
	enabled=1 
	priority=1
error-1.txt

8 REPLIES 8

Master Guru
@Raj ji

The HDF 3.0.3 release is only compatible with IBM Power systems.

For other systems you need to use HDF 3.0.2 or HDF 3.1.x versions.

Thank you,

Matt

Explorer

Thanks for the Quick response , I have tried using 3.0.2 tarball and repo . Still facing the same issue . However I have installed mpack for 3.0.3 . Dont know how to remove this Mpack .

Explorer

When I installed , MPACK for 3.0.2 . I get this error below :

sudo ambari-server install-mpack --mpack=/tmp/hdf-ambari-mpack-3.0.2.0-76.tar.gz --verbose
Using python  /usr/bin/python
Installing management pack
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Installing management pack /tmp/hdf-ambari-mpack-3.0.2.0-76.tar.gz
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
INFO: Download management pack to temp location /var/lib/ambari-server/data/tmp/hdf-ambari-mpack-3.0.2.0-76.tar.gz
INFO: Loading properties from /etc/ambari-server/conf/ambari.properties
Traceback (most recent call last):
  File "/usr/sbin/ambari-server.py", line 950, in <module>
    mainBody()
  File "/usr/sbin/ambari-server.py", line 920, in mainBody
    main(options, args, parser)
  File "/usr/sbin/ambari-server.py", line 872, in main
    action_obj.execute()
  File "/usr/sbin/ambari-server.py", line 78, in execute
    self.fn(*self.args, **self.kwargs)
  File "/usr/lib/python2.6/site-packages/ambari_server/setupMpacks.py", line 896, in install_mpack
    (mpack_metadata, mpack_name, mpack_version, mpack_staging_dir, mpack_archive_path) = _install_mpack(options, replay_mode)
  File "/usr/lib/python2.6/site-packages/ambari_server/setupMpacks.py", line 697, in _install_mpack
    tmp_root_dir = expand_mpack(tmp_archive_path)
  File "/usr/lib/python2.6/site-packages/ambari_server/setupMpacks.py", line 150, in expand_mpack
    archive_root_dir = get_archive_root_dir(archive_path)
  File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/tar_archive.py", line 78, in get_archive_root_dir
    names = tar.getnames()
  File "/usr/lib64/python2.7/tarfile.py", line 1813, in getnames
    return [tarinfo.name for tarinfo in self.getmembers()]
  File "/usr/lib64/python2.7/tarfile.py", line 1805, in getmembers
    self._load()        # all members, we first have to
  File "/usr/lib64/python2.7/tarfile.py", line 2380, in _load
    tarinfo = self.next()
  File "/usr/lib64/python2.7/tarfile.py", line 2315, in next
    self.fileobj.seek(self.offset)
  File "/usr/lib64/python2.7/gzip.py", line 434, in seek
    self.read(1024)
  File "/usr/lib64/python2.7/gzip.py", line 261, in read
    self._read(readsize)
  File "/usr/lib64/python2.7/gzip.py", line 308, in _read
    self._read_eof()
  File "/usr/lib64/python2.7/gzip.py", line 347, in _read_eof
    hex(self.crc)))
IOError: CRC check failed 0xdc6e2773 != 0xf9fc1ddL



Explorer

How do I start with fresh install now when I have already installed mpack for 3.0.3 and 3.0.3 HDF . Do you have any command to remove all the files which I have installed.

Rising Star

Hi @Raj ji,

You can try uninstalling the mpack with the following command:

ambari-server uninstall-mpack --mpack-name=hdf-ambari-mpack --verbose

And then installing the appropriate management pack

ambari-server install-mpack --mpack=hdf-ambari-mpack-3.0.2.0-76.tar.gz --verbose

Make sure to stop ambari first and then start after you've installed the correct mpack.

@Raj ji As the warning says you should not install this build 3.0.3 unless you are on IBM Power System. Are you on IBM Power Systems? If not, you should install 3.0.2.

HTH

Explorer

thanks Felix , However ,I have tried installing the 3.0.2 Same error . please find the attached error for your reference when I installed with 3.0.2error-302.txt .

Explorer

tar.pngHi All,

I have only these options , I do not have good internet connection . However, I have created a repo . but I can see only tar files in the hdf repo tar ball.

http://public-repo-1.hortonworks.com/HDF/centos7/3.x/updates/3.0.2.0

https://s3.amazonaws.com/public-repo-1.hortonworks.com/HDF/centos7/3.x/updates/3.0.2.0/HDF-3.0.2.0-c...

If you download and add to the Ambari Manage -> versions-> add the local repo URL (http://192.168.1.8/repo/HDF/)

and get this error

Some of the repositories failed validation. Make changes to the base url or skip validation if you are sure that urls are correct

HOwever When I look at the HDF repo directory it has only tar files of services . I do not think it is a valid repo .