Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Unable to connect to Ambari Server after IP address change

New Contributor

Hi Team,

I have changed the IP Address of ambari server as well other slaves nodes on the cluster.After the IP address I updated /etc/hosts in all nodes and restarted ambari-agent and ambari-server process.

But when I login ambari UI using admin/admin it takes some time and tells that "

Unable to connect to Ambari Server. Confirm Ambari Server is running and you can reach Ambari Server from this machine

"

Please note that there is no change in hostname or FQDN.

also tried with "curl http://127.0.0.1:8080" it returns bad request but I when I tried with "curl http://<ip of eth0>:8080" it returns proper response. Not if I am missing something somewhere.

Can you please assist with this?

Regards,

Venkatesan

1 REPLY 1

Super Mentor

@Venkatesan G

Couple of things we should check.

1. The machine where you are running the Browser are you able to resolve the FQDN of ambari (not the IP Address)? You will need to make sure that on your Browser Machine also you will need to change the ambari IP/Hostname mapping inside the "/etc/hosts" file.

# telnet  $AMBARI_HOSTNAME  8080

2. Please check the ambari server host and verify the port is bind to the correct Hostname (address).

# netstat -tnlpa | grep 8080

3. Run the FQDN display command on ambari host and agent hosts to confirm the FQDN is correct.

4. As the ambari IP Address is changed so you will need to make sure that from the machine where you are running the browser, you are able to access the Ambari Hostname & port. Many times browser picks up the Ambari UI page from the browsers cache. So please try opening the browser in "Incognito Mode" (Chrome) / "Private Window Mode" (Firefox)

.