Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Unable to connect to Spark History Server Web UI (Cloudera Enterprise 6.3.4)

avatar
New Contributor

Accessing the URL on port 18088 returns a ERR_SSL_PROTOCOL_ERROR error in Chrome.

 

history server logs have the following:

 

11:25:29.130 AM	WARN	HttpParser	
Illegal character 0x16 in state=START for buffer HeapByteBuffer@1af6bd16[p=1,l=517,c=8192,r=516]={\x16<<< ...}
11:25:29.130 AM	WARN	HttpParser	
Illegal character 0x16 in state=START for buffer HeapByteBuffer@21158554[p=1,l=517,c=8192,r=516]={\x16<<< ...}
11:25:29.130 AM	WARN	HttpParser	
bad HTTP parsed: 400 Illegal character 0x16 for HttpChannelOverHttp@2390a367{r=0,c=false,a=IDLE,uri=null}
11:25:29.131 AM	WARN	HttpParser	
bad HTTP parsed: 400 Illegal character 0x16 for HttpChannelOverHttp@7843db5f{r=0,c=false,a=IDLE,uri=null}

 

Note: some lines truncated to avoid exposing data.

 

There was a similar post regarding Schema Registry UI in Ambari but the solution doesn't appear to be applicable here (though I suspect the issue is similar).

 

Any thoughts?

1 ACCEPTED SOLUTION

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
3 REPLIES 3

avatar
Contributor

- Do we have enabled SSL for the Spark UI?

- If not, are we able to access the URL with the HTTP protocol? Also try with different browser and in Private Browsing mode.

- Have we tried accessing the URL with the CURL command?

- Do we have SPNEGO enabled for the cluster?

avatar
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar
New Contributor

This appears to be the cause. Switching to MS Edge avoided the HSTS feature in Chrome.

 

Will look at enabling HTTPS on all UIs though since that is the correct solution in the longterm (spark.ssl.historyServer.enabled option is currently set to false).