Support Questions
Find answers, ask questions, and share your expertise

Unable to connect to spark-sql cli

Expert Contributor

I am using CDH 5.5.7 quick start VM which has Spark 1.6.0 running. I am trying to connect to the spark-sql cli but it fails. According to this link by issuing spark-sql command I should be able to enter the cli but I get the below error.

[cloudera@quickstart ~]$ spark-sql
-bash: spark-sql: command not found

I have also tried the below and getting the same error

[cloudera@quickstart ~]$ ./bin/spark-sql
-bash: ./bin/spark-sql: No such file or directory

Any help is much appreciated.

5 REPLIES 5

If spark is not present at location ./bin/spark-sql, just verify the correct folder and run sh. Secondly check the user you are logged into system and have sufficient permission or a Hadoop group member.

Expert Contributor

From the same directory I can fire spark-shell and that works without any hassle. Moreover I am using the VM and I am sure that the use I am using has the root access.

If other components are present and working that means someone deleted the file cause in HDP and Biginsight both have no issue and they shipped with all components.

Expert Contributor

I am using the vm version of the distribution in my laptop and hence there is no chance of any file deletion.

New Contributor

try spark-shell command