Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Unable to get Beeline

New Contributor

Hi 

I have set Up Cloudera services using Cloudera manager 5.16.2. I have installed hive and its respective Hive Server 2 and Hive metastore on the same node.

Although upon setting up of Hive Server 2 I am not getting beeline CLI by default on that node when firing beeline Command from my CentOs 7 terminal i am getting /usr/lib/hive/bin/beeline: No such file or directory.

Please help me, anyone.I have been trying to solve this problem From last 8 hours or so but not getting any accurate solution.

 

 

Thanks in Advance

1 REPLY 1

Super Collaborator

Hi @Rishab ,

 

Thanks for reaching out to Cloudera community. 

 

Have you tried to deploy the client configuration to the HiveServer2 host? Please do below:

From CM UI > Home > Status tab, click to the right of the cluster name and select Deploy Client Configuration, click it. More details from below doc:

https://docs.cloudera.com/documentation/enterprise/5-16-x/topics/cm_mc_client_config.html#cmug_topic...

 

Thanks and hope this helps,

Li

Li Wang, Technical Solution Manager


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:

Terms of Service

Community Guidelines

How to use the forum